Add srain.

Srain is a modern IRC client written in GTK.

Features
========

- Fully open source
- RFC {1459,2812} compatible
- Partial IRCv3 support
- Multi-platform support
- Act like modern IM client
  - Graphical user interface
  - Convenient connection panel
  - Interactive channel search
  - Forward message in one click
  - URL preview
  - Desktop notificaion
  - Special optimization for bridge/relay bot
- Act like geek IRC client
  - Anything can be done via commands
  - Fine-grained configuration with hot update support
  - Regex based message render and filter mechanisms
  - IPC based plugin system (TODO)
This commit is contained in:
nia 2020-01-28 18:44:42 +00:00
parent dedff93d55
commit f24752d230
7 changed files with 104 additions and 0 deletions

View File

@ -4576,6 +4576,7 @@ SUBDIR+= squirrelmail-avelsieve
SUBDIR+= squirrelmail-chg_sasl_passwd
SUBDIR+= squirrelmail-compatibility
SUBDIR+= squirrelmail-vlogin
SUBDIR+= srain
SUBDIR+= src
SUBDIR+= srecord
SUBDIR+= srvx

22
srain/DESCR Normal file
View File

@ -0,0 +1,22 @@
Srain is a modern IRC client written in GTK.
Features
========
- Fully open source
- RFC {1459,2812} compatible
- Partial IRCv3 support
- Multi-platform support
- Act like modern IM client
- Graphical user interface
- Convenient connection panel
- Interactive channel search
- Forward message in one click
- URL preview
- Desktop notificaion
- Special optimization for bridge/relay bot
- Act like geek IRC client
- Anything can be done via commands
- Fine-grained configuration with hot update support
- Regex based message render and filter mechanisms
- IPC based plugin system (TODO)

43
srain/Makefile Normal file
View File

@ -0,0 +1,43 @@
# $NetBSD$
DISTNAME= srain-1.0.0rc9999
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_GITHUB:=SrainApp/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://srain.im/
COMMENT= Modern IRC client written in GTK
LICENSE= gnu-gpl-v3
HAS_CONFIGURE= yes
USE_TOOLS+= pkg-config gmake
USE_TOOLS+= msgfmt msgmerge xgettext
CONFIGURE_ARGS+= --prefix=${PREFIX}
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+= --disable-debug
BUILD_TARGET= default
MAKE_FLAGS+= MAKE=${GMAKE:Q}
MAKE_FLAGS+= INSTALL=${INSTALL:Q}
AUTO_MKDIRS= yes
OWN_DIRS+= ${PKG_SYSCONFDIR}/srain
CONF_FILES+= share/examples/srain/builtin.cfg \
${PKG_SYSCONFDIR}/srain/builtin.cfg
# XXX xgettext: unknown option -- package-name=Srain
_TOOLS_USE_PKGSRC.xgettext= yes
.include "../../devel/libconfig/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../net/libsoup/buildlink3.mk"
.include "../../security/libsecret/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/gtk3/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

13
srain/PLIST Normal file
View File

@ -0,0 +1,13 @@
@comment $NetBSD$
bin/srain
share/applications/im.srain.Srain.desktop
share/examples/srain/builtin.cfg
share/icons/hicolor/scalable/apps/im.srain.Srain.png
share/locale/ru/LC_MESSAGES/srain.mo
share/locale/zh_CN/LC_MESSAGES/srain.mo
share/metainfo/im.srain.Srain.appdata.xml
share/srain/themes/bubble.css
share/srain/themes/default-bubble-dark.css
share/srain/themes/default-bubble.css
share/srain/themes/default-min.css
share/srain/themes/reset.css

3
srain/TODO Normal file
View File

@ -0,0 +1,3 @@
Cannot connect to servers.
"Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files"

7
srain/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (srain-1.0.0rc9999.tar.gz) = 6f4b097a3fffb33b8dc732cd3b14b6bbbe632a42
RMD160 (srain-1.0.0rc9999.tar.gz) = be881ba7ee418fb3c0f46d5f1a8072829e7c7e4d
SHA512 (srain-1.0.0rc9999.tar.gz) = c3c760f3a88e82a4716d7f2afd8436b99f0058ba546b45b38ea1b63cde348be492bac3f3c9301ac5a71c3e23e5db2046ff29e31cf47f2dfd803598f2f46c241e
Size (srain-1.0.0rc9999.tar.gz) = 1015541 bytes
SHA1 (patch-data_Makefile) = 9330228df6a9648c332417a2658417a8ed445499

View File

@ -0,0 +1,15 @@
$NetBSD$
Install config files to examples.
--- data/Makefile.orig 2019-10-07 15:01:52.000000000 +0000
+++ data/Makefile
@@ -21,7 +21,7 @@ $(RES): srain.gresource.xml $(GLADES) $(
.PHONY: config
config: builtin.cfg
- $(INSTALL) -Dm644 "$<" "$(DESTDIR)$(PACKAGE_CONFIG_DIR)/$(PACKAGE)/$<"
+ $(INSTALL) -Dm644 "$<" "$(DESTDIR)$(PREFIX)/share/examples/srain/$<"
.PHONY: icons
icons: icons/scalable/srain.png