py-qwt-qt5: close TODO item

This commit is contained in:
Tobias Nygren 2020-08-03 18:25:21 +02:00
parent 9e250ce685
commit f95c8a8ac9
4 changed files with 16 additions and 14 deletions

View File

@ -1,12 +0,0 @@
Fails with clang:
> /tmp/pkgsrc-obj/wip/py-qwt-qt5/work/PyQt-Qwt-pyqt-qwt-1.02.00/Qwt/sipQwtQwtPowerTransform.cpp:231:65: error: object of type 'QwtPowerTransform' cannot be assigned because its copy assignment operator is implicitly deleted
> reinterpret_cast< ::QwtPowerTransform *>(sipDst)[sipDstIdx] = *reinterpret_cast< ::QwtPowerTransform *>(sipSrc);
^
> /tmp/pkgsrc-obj/wip/py-qwt-qt5/work/.buildlink/qwt-6.1.4/include/qwt_transform.h:139:18: note: copy assignment operator of 'QwtPowerTransform' is implicitly deleted because field 'd_exponent' is of const-qualified type 'const double'
> const double d_exponent;
Removing the const qualifier in the qwt6-qt5 package seems to solve it,
but maybe it should do an element-wise copy instead of trying to
use the copy operator?

View File

@ -4,5 +4,6 @@ SHA1 (pyqt-qwt-1.02.00.tar.gz) = d1c113c5c8ae504bfc479dafdad94a2e459ecf09
RMD160 (pyqt-qwt-1.02.00.tar.gz) = a25d19cd71baf264b03c02ecd2c86dd4fb3b560c
SHA512 (pyqt-qwt-1.02.00.tar.gz) = f2b54bd4097b726bcf4df897b910d49489efd2bc9d06d239037b0ecb7ed1420c76499e65b84a49efe2e8ba2313857ece92d8d50d157ccc38fda0cc0dac5ab178
Size (pyqt-qwt-1.02.00.tar.gz) = 103588 bytes
SHA1 (patch-mk__distinfo.py) = c1f863f827720d0b0f04f592a88901b4ffc15ca6
SHA1 (patch-mk__distinfo.py) = 180ce6d00f21142878f2a01805921d5c1fd63637
SHA1 (patch-sip_qwt.sip) = f2491af157af22410ac78f1fb8bf05b332feb58e
SHA1 (patch-sip_qwt__transform.sip) = 1e6f0e26e5cd5368bf39ce8ade529fef8464e34a

View File

@ -8,7 +8,7 @@ Work around DESTDIR installation issue
else:
fn_name = fn
+ if (fn.startswith(sys.prefix)):
+ if (fn.startswith(sys.prefix + "/")):
+ fn = os.environ.get("DESTDIR") + fn
+ if (os.path.isdir(fn)):
+ continue

View File

@ -0,0 +1,13 @@
$NetBSD$
https://github.com/GauiStori/PyQt-Qwt/commit/8f6e01a10f29417214ae2266f3e5c13443e989a0
--- sip/qwt_transform.sip.orig 2019-02-23 12:55:34.000000000 +0000
+++ sip/qwt_transform.sip
@@ -123,4 +123,6 @@ public:
virtual QwtTransform *copy() const;
+private:
+ QwtPowerTransform& operator=(const QwtPowerTransform&);
};