+oggfwd: pipes an ogg stream to an icecast server

This commit is contained in:
AcidBear 2020-02-13 18:25:52 +03:00
parent 1badeecace
commit fdf0e674d5
5 changed files with 51 additions and 0 deletions

1
oggfwd/DESCR Normal file
View File

@ -0,0 +1 @@
Just reads from stdin and sends to icecast server using libshout

22
oggfwd/Makefile Normal file
View File

@ -0,0 +1,22 @@
# $NetBSD$
DISTNAME= oggfwd
PKGNAME= oggfwd-20150329
CATEGORIES= multimedia
GIT_REPO= https://r-w-x.org/r/oggfwd.git
MAINTAINER= jake.slazenger@yandex.com
HOMEPAGE= http://v2v.cc/~j/oggfwd/
COMMENT= pipes an ogg stream to an icecast server.
LICENSE= gnu-gpl-v2
USE_LANGUAGES= c
# url2pkg-marker (please do not remove this line.)
.include "../../audio/libshout/buildlink3.mk"
.include "../../audio/libvorbis/buildlink3.mk"
.include "../../multimedia/libogg/buildlink3.mk"
.include "../../multimedia/libtheora/buildlink3.mk"
.include "../../wip/mk/git-package.mk"
.include "../../mk/bsd.pkg.mk"

3
oggfwd/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD$
bin/oggfwd
man/man1/oggfwd.1

7
oggfwd/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (oggfwd.git) = e4328426a21175db2df4e36630f67d31ca9631fd
RMD160 (oggfwd.git) = 9ff453afe215fa355645b1d0638fd45f6216255b
SHA512 (oggfwd.git) = 156c6219d8dfd99c9ce754cc55c45288ae38c3302b72fd007ddd2c93499d31f805850e9fa63a73525d7a8a555eddf650d824dcce48cbba22fff8327d5ae9433a
Size (oggfwd.git) = 17791 bytes
SHA1 (patch-Makefile) = 58aec68ba72bc8a44ec678b0279e56e9ed63da60

View File

@ -0,0 +1,18 @@
$NetBSD$
--- Makefile.orig 2020-02-13 14:26:47.000000000 +0000
+++ Makefile
@@ -23,9 +23,10 @@ ${PROG}: ${SRC}
${CC} ${CFLAGS} ${PTHREADFLAGS} ${INCLUDEFLAGS} -o ${PROG} $< ${LINKFLAGS}
install: ${PROG}
- ${INSTALL} -c -m 555 -o root -g bin ${PROG} ${BINDIR}
- test -d ${MAN1DIR} || ${INSTALL} -d -o root ${MAN1DIR}
- ${INSTALL} -c -m 444 -o root -g bin ${MAN} ${MAN1DIR}
+ ${INSTALL} -d ${DESTDIR}/${BINDIR}
+ ${INSTALL} -c -m 555 ${PROG} ${DESTDIR}/${BINDIR}
+ ${INSTALL} -d ${DESTDIR}/${MAN1DIR}
+ ${INSTALL} -c -m 444 ${MAN} ${DESTDIR}/${MAN1DIR}
clean:
-@rm -f ${PROG} *~ core *.core