This commit is contained in:
OHt 2011-12-05 15:13:33 +00:00 committed by Thomas Klausner
parent 3154edb2a1
commit fe79e410c4
7 changed files with 140 additions and 0 deletions

2
fribid/DESCR Normal file
View File

@ -0,0 +1,2 @@
FriBID is a web browser plugin for BankID,
a kind of electronic ID (e-legitimation) that's used in Sweden.

24
fribid/Makefile Normal file
View File

@ -0,0 +1,24 @@
# $NetBSD: Makefile,v 1.1.1.1 2011/12/05 15:13:33 oht Exp $
DISTNAME= fribid-1.0.0
PKGNAME= fribid-1.0.0
CATEGORIES= security
MASTER_SITES= http://fribid.se/releases/source/
MAINTAINER= oht@users.sourceforge.net
HOMEPAGE= http://fribid.se/
EXTRACT_SUFX= .tar.bz2
COMMENT= FriBID is a web browser plugin for BankID
USE_TOOLS+= gmake pkg-config
LICENSE= mit
CONFIGURE_ARGS+= --prefix=${PREFIX} --mandir=${PKGMANDIR}
HAS_CONFIGURE= yes
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

28
fribid/PLIST Normal file
View File

@ -0,0 +1,28 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2011/12/05 15:13:33 oht Exp $
bin/pkglint
bin/plist-clash
lib/fribid/libfribidplugin.so
lib/fribid/sign
lib/perl5/vendor_perl/5.14.0/${MACHINE_ARCH}-${LOWER_OPSYS}-thread-multi/auto/Digest/.packlist
lib/perl5/vendor_perl/5.14.0/${MACHINE_ARCH}-${LOWER_OPSYS}-thread-multi/auto/Digest/SHA1/.packlist
lib/perl5/vendor_perl/5.14.0/${MACHINE_ARCH}-${LOWER_OPSYS}-thread-multi/auto/Digest/SHA1/SHA1.bs
lib/perl5/vendor_perl/5.14.0/${MACHINE_ARCH}-${LOWER_OPSYS}-thread-multi/auto/Digest/SHA1/SHA1.so
lib/perl5/vendor_perl/5.14.0/${MACHINE_ARCH}-${LOWER_OPSYS}-thread-multi/auto/enum/.packlist
lib/perl5/vendor_perl/5.14.0/${MACHINE_ARCH}-${LOWER_OPSYS}-thread-multi/auto/pkgsrc/Dewey/.packlist
lib/perl5/vendor_perl/5.14.0/${MACHINE_ARCH}-${LOWER_OPSYS}-thread-multi/auto/pkgsrc/Dewey/Dewey.bs
lib/perl5/vendor_perl/5.14.0/${MACHINE_ARCH}-${LOWER_OPSYS}-thread-multi/auto/pkgsrc/Dewey/Dewey.so
lib/perl5/vendor_perl/5.14.0/${MACHINE_ARCH}-${LOWER_OPSYS}-thread-multi/auto/pkgsrc/Dewey/autosplit.ix
lib/perl5/vendor_perl/5.14.0/${MACHINE_ARCH}-${LOWER_OPSYS}-thread-multi/pkgsrc/Dewey.pm
lib/perl5/vendor_perl/man/man3/Digest.3
lib/perl5/vendor_perl/man/man3/Digest::SHA1.3
lib/perl5/vendor_perl/man/man3/Digest::base.3
lib/perl5/vendor_perl/man/man3/Digest::file.3
lib/perl5/vendor_perl/man/man3/enum.3
lib/perl5/vendor_perl/man/man3/pkgsrc::Dewey.3
man/cat1/pkglint.0
man/man1/pkglint.1
man/man7/fribid.7.gz
man/sv/man7/fribid.7.gz
share/fribid/ui/sign.xml
share/pkglint/deprecated.map
share/pkglint/makevars.map

8
fribid/distinfo Normal file
View File

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2011/12/05 15:13:33 oht Exp $
SHA1 (fribid-1.0.0.tar.bz2) = c105a49bdf94328618c9a2b5f324169f2591f04d
RMD160 (fribid-1.0.0.tar.bz2) = c31f23215d6e39f9e6cbbf7af10b175bd446290a
Size (fribid-1.0.0.tar.bz2) = 117355 bytes
SHA1 (patch-aa) = 6de2154d486a38b7f464b1414db64e56a38a18c0
SHA1 (patch-ab) = 27bfed21bf932d21822b2d990670f186ddd23b80
SHA1 (patch-ac) = 641fadafc8340a1a2c2ed202799ef89be63e5a32

32
fribid/patches/patch-aa Normal file
View File

@ -0,0 +1,32 @@
$NetBSD: patch-aa,v 1.1.1.1 2011/12/05 15:13:33 oht Exp $
patch-aa
--- plugin/pluginutil.c.orig 2011-09-25 13:59:56.000000000 +0200
+++ plugin/pluginutil.c 2011-12-02 08:20:31.000000000 +0100
@@ -6,7 +6,9 @@
#include <sys/types.h>
#include <sys/socket.h>
#include <netdb.h>
-
+#ifndef NI_MAXHOST
+#define NI_MAXHOST 1025
+#endif
#include <npapi.h>
#include <npruntime.h>
@@ -143,6 +145,7 @@
if (!ai) return NULL;
char ip[NI_MAXHOST];
+ const char *ipp = &ip[0] ;
if (getnameinfo(ai->ai_addr, ai->ai_addrlen, ip, NI_MAXHOST,
NULL, 0, NI_NUMERICHOST) != 0) {
freeaddrinfo(firstAddrInfo);
@@ -150,7 +153,7 @@
}
freeaddrinfo(firstAddrInfo);
- return strdup(ip);
+ return strndup(ipp,NI_MAXHOST);
}
/**

14
fribid/patches/patch-ab Normal file
View File

@ -0,0 +1,14 @@
$NetBSD: patch-ab,v 1.1.1.1 2011/12/05 15:13:33 oht Exp $
patch-ab
--- Makefile.orig 2011-09-25 13:59:56.000000000 +0200
+++ Makefile 2011-12-02 09:41:12.000000000 +0100
@@ -20,7 +20,8 @@
# THE SOFTWARE.
#
-SUBDIRS=client plugin translations doc
+#SUBDIRS=client plugin translations doc
+SUBDIRS=client plugin doc
DISTNAME=`./configure --internal--get-define=BINNAME`-`./configure --internal--get-define=PACKAGEVERSION`

32
fribid/patches/patch-ac Normal file
View File

@ -0,0 +1,32 @@
$NetBSD: patch-ac,v 1.1.1.1 2011/12/05 15:13:33 oht Exp $
patch-ac
--- common/pipe.c.orig 2011-09-25 13:59:56.000000000 +0200
+++ common/pipe.c 2011-12-02 09:44:27.000000000 +0100
@@ -101,10 +101,25 @@
}
}
+char *strdup(const char *str)
+{
+ int n = strlen(str) + 1;
+ char *dup = malloc(n);
+ if(dup)
+ {
+ strcpy(dup, str);
+ }
+ return dup;
+}
+
+
char *pipe_readString(FILE *in) {
int length = pipe_readInt(in);
- if (length <= 0) return strdup("");
-
+ if (length <= 0) {
+ char a = '\0';
+ char *pa = &a;
+ return strdup(pa);
+ }
char *data = malloc(length +1);
if (!data) {
pipeError();