+new, update

This commit is contained in:
K.I.A.Derouiche 2019-03-03 01:02:03 +01:00
parent c5b126676c
commit fefc166fb1
22 changed files with 611 additions and 25 deletions

View File

@ -1,7 +1,6 @@
LGOPY is a tool for Algorithmic Differentiation (AD) and
Taylor polynomial approximations. ALGOPY makes it possible to perform
computations on scalar and polynomial matrices. It is designed to be as
compatible to numpy as possible. I.e. views, broadcasting and most functions
of numpy can be performed on polynomial matrices. Exampels are dot,trace,qr,
solve, inv,eigh. The reverse mode of AD is also supported by a simple
code evaluation tracer.
ALGOPY is a tool for Algorithmic Differentiation (AD) and Taylor polynomial
approximations. ALGOPY makes it possible to perform computations on scalar
and polynomial matrices. It is designed to be as compatible to numpy as
possible. I.e. views, broadcasting and most functions of numpy can be performed
on polynomial matrices. Exampels are dot,trace,qr,solve, inv,eigh. The reverse
mode of AD is also supported by a simple code evaluation tracer

View File

@ -1,22 +1,25 @@
# $NetBSD: Makefile,v 1.5 2013/08/31 22:13:21 jihbed Exp $
DISTNAME= algopy-0.5.0
# $NetBSD$
#Update
DISTNAME= algopy-0.5.7
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= math python
MASTER_SITES= ${MASTER_SITE_PYPI:=a/algopy/}
MASTER_SITES= https://files.pythonhosted.org/packages/1e/44/e22102b72f0eb3118d4a9e4815104515e1996c3695c82047eeede8a41f89/
EXTRACT_SUFX= .zip
MAINTAINER= jihbed.research@gmail.com
HOMEPAGE= http://packages.python.org/algopy
COMMENT= Taylor Arithmetic Computation and Algorithmic Differentiation
HOMEPAGE= https://pythonhosted.org/algopy/
COMMENT= ALGOPY: Taylor Arithmetic Computation and Algorithmic Differentiation
LICENSE= modified-bsd
WRKSRC= ${WRKDIR}/algopy-0.5.0
DEPENDS+= ${PYPKGPREFIX}-nose>=1.3.7:../../devel/py-nose
USE_LANGUAGES= # none
do-test:
${RUN} cd ${WRKSRC}/algopy; ${SETENV} ${TEST_ENV} ${PYTHONBIN} test_utils.py
PYDISTUTILSPKG = yes
do-test:
${RUN} cd ${WRKSRC}/algopy; ${SETENV} ${TEST_ENV} ${PYTHONBIN} run_tests.py
.include "../../lang/python/extension.mk"
.include "../../math/py-numpy/buildlink3.mk"
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,11 +1,13 @@
@comment $NetBSD$
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/algopy/__init__.py
${PYSITELIB}/algopy/__init__.pyc
${PYSITELIB}/algopy/__init__.pyo
${PYSITELIB}/algopy/_npversion.py
${PYSITELIB}/algopy/_npversion.pyc
${PYSITELIB}/algopy/_npversion.pyo
${PYSITELIB}/algopy/_six.py
${PYSITELIB}/algopy/_six.pyc
${PYSITELIB}/algopy/_six.pyo
${PYSITELIB}/algopy/base_type.py
${PYSITELIB}/algopy/base_type.pyc
${PYSITELIB}/algopy/base_type.pyo
@ -15,6 +17,12 @@ ${PYSITELIB}/algopy/compound.pyo
${PYSITELIB}/algopy/exact_interpolation.py
${PYSITELIB}/algopy/exact_interpolation.pyc
${PYSITELIB}/algopy/exact_interpolation.pyo
${PYSITELIB}/algopy/fft/__init__.py
${PYSITELIB}/algopy/fft/__init__.pyc
${PYSITELIB}/algopy/fft/__init__.pyo
${PYSITELIB}/algopy/fft/fft.py
${PYSITELIB}/algopy/fft/fft.pyc
${PYSITELIB}/algopy/fft/fft.pyo
${PYSITELIB}/algopy/globalfuncs.py
${PYSITELIB}/algopy/globalfuncs.pyc
${PYSITELIB}/algopy/globalfuncs.pyo
@ -60,6 +68,9 @@ ${PYSITELIB}/algopy/tests/test_globalfuncs.pyo
${PYSITELIB}/algopy/tests/test_linalg.py
${PYSITELIB}/algopy/tests/test_linalg.pyc
${PYSITELIB}/algopy/tests/test_linalg.pyo
${PYSITELIB}/algopy/tests/test_npversion.py
${PYSITELIB}/algopy/tests/test_npversion.pyc
${PYSITELIB}/algopy/tests/test_npversion.pyo
${PYSITELIB}/algopy/tests/test_nthderiv.py
${PYSITELIB}/algopy/tests/test_nthderiv.pyc
${PYSITELIB}/algopy/tests/test_nthderiv.pyo
@ -90,6 +101,9 @@ ${PYSITELIB}/algopy/tracer/tests/test_output/__init__.pyo
${PYSITELIB}/algopy/tracer/tests/test_tracer.py
${PYSITELIB}/algopy/tracer/tests/test_tracer.pyc
${PYSITELIB}/algopy/tracer/tests/test_tracer.pyo
${PYSITELIB}/algopy/tracer/tests/test_tracer_complex.py
${PYSITELIB}/algopy/tracer/tests/test_tracer_complex.pyc
${PYSITELIB}/algopy/tracer/tests/test_tracer_complex.pyo
${PYSITELIB}/algopy/tracer/tracer.py
${PYSITELIB}/algopy/tracer/tracer.pyc
${PYSITELIB}/algopy/tracer/tracer.pyo
@ -114,6 +128,12 @@ ${PYSITELIB}/algopy/utpm/tests/test_special_function_identities.pyo
${PYSITELIB}/algopy/utpm/tests/test_utpm.py
${PYSITELIB}/algopy/utpm/tests/test_utpm.pyc
${PYSITELIB}/algopy/utpm/tests/test_utpm.pyo
${PYSITELIB}/algopy/utpm/tests/test_utpm_complex.py
${PYSITELIB}/algopy/utpm/tests/test_utpm_complex.pyc
${PYSITELIB}/algopy/utpm/tests/test_utpm_complex.pyo
${PYSITELIB}/algopy/utpm/tests/test_utpm_convenience.py
${PYSITELIB}/algopy/utpm/tests/test_utpm_convenience.pyc
${PYSITELIB}/algopy/utpm/tests/test_utpm_convenience.pyo
${PYSITELIB}/algopy/utpm/utpm.py
${PYSITELIB}/algopy/utpm/utpm.pyc
${PYSITELIB}/algopy/utpm/utpm.pyo

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.4 2013/08/31 22:13:21 jihbed Exp $
$NetBSD$
SHA1 (algopy-0.5.0.tar.gz) = 205a0a589daf8942e07b28f11d53eab5298f36dc
RMD160 (algopy-0.5.0.tar.gz) = aa1a4f68ef57dc3e3d0112fd770152c9494b20f2
Size (algopy-0.5.0.tar.gz) = 136197 bytes
SHA1 (algopy-0.5.7.zip) = 415f6c57521dff621ed8627106bd0588f94342b1
RMD160 (algopy-0.5.7.zip) = afde10c39cdb717c11586c6f19710581f646b05c
SHA512 (algopy-0.5.7.zip) = 1d2cb62154f7bc344605e2db1d90125a76b93e99628056ef007a27b05546d0af3e1d52587dc3217d03118f8dddac298742c303ae9d39185ab33375e56ae3a1ba
Size (algopy-0.5.7.zip) = 189516 bytes

2
py-idx2numpy/DESCR Normal file
View File

@ -0,0 +1,2 @@
A Python package which provides tools to convert files to and from IDX
format (described at http://yann.lecun.com/exdb/mnist/) into numpy.ndarray

19
py-idx2numpy/Makefile Normal file
View File

@ -0,0 +1,19 @@
# $NetBSD$
DISTNAME= idx2numpy-1.2.2
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= math
MASTER_SITES= https://files.pythonhosted.org/packages/23/6b/abab4652eb249f432c62431907c8de32bdcedb5abdf869ff86653efff981/
MAINTAINER= jihbed.research@gmail.com
HOMEPAGE= https://github.com/ivanyu/idx2numpy
COMMENT= Provides tools to convert files to and from IDX format
LICENSE= mit
DEPENDS+= ${PYPKGPREFIX}-six>=1.12.0:../../lang/py-six
USE_LANGUAGES= # none
.include "../../lang/python/egg.mk"
.include "../../math/py-numpy/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

25
py-idx2numpy/PLIST Normal file
View File

@ -0,0 +1,25 @@
@comment $NetBSD$
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/idx2numpy/FormatError.py
${PYSITELIB}/idx2numpy/__init__.py
${PYSITELIB}/idx2numpy/FormatError.pyo
${PYSITELIB}/idx2numpy/FormatError.pyc
${PYSITELIB}/idx2numpy/__init__.pyo
${PYSITELIB}/idx2numpy/__init__.pyc
${PYSITELIB}/idx2numpy/converters.pyo
${PYSITELIB}/idx2numpy/converters.pyc
${PYSITELIB}/idx2numpy/version.pyo
${PYSITELIB}/idx2numpy/version.pyc
${PYSITELIB}/idx2numpy/converters.py
${PYSITELIB}/idx2numpy/test/__init__.py
${PYSITELIB}/idx2numpy/test/__init__.pyo
${PYSITELIB}/idx2numpy/test/__init__.pyc
${PYSITELIB}/idx2numpy/test/converters_test.pyo
${PYSITELIB}/idx2numpy/test/converters_test.pyc
${PYSITELIB}/idx2numpy/test/converters_test.py
${PYSITELIB}/idx2numpy/version.py

6
py-idx2numpy/distinfo Normal file
View File

@ -0,0 +1,6 @@
$NetBSD$
SHA1 (idx2numpy-1.2.2.tar.gz) = 7ecf38493e6e5aa84a4cfa53631a23b4cb386533
RMD160 (idx2numpy-1.2.2.tar.gz) = 9ae2467fbba9ad5b07f5c4472f61f8ef1432fefb
SHA512 (idx2numpy-1.2.2.tar.gz) = f4576239da09df8d9b58f8a4d1ddcf04cb0f8ea5785e00efcc5fd9f722f1193d65f12645be546f344614a652c46ec2c0de2dbd7910e01d0c120fb76ca6e252e3
Size (idx2numpy-1.2.2.tar.gz) = 7051 bytes

3
py-mapy-package/DESCR Normal file
View File

@ -0,0 +1,3 @@
Tool to integrate different pre-processor platforms (Abaqus, NASTRAN, SimXpert).
The models can be loaded in the Python environment and passed from one
platform to another

18
py-mapy-package/Makefile Normal file
View File

@ -0,0 +1,18 @@
# $NetBSD$
DISTNAME= mapy_package-0.15.0
PKGNAME= ${PYPKGPREFIX}-mapy-package-0.15.0
CATEGORIES= math
MASTER_SITES= https://files.pythonhosted.org/packages/85/a9/d7f88ec8a9d768de94c60584645f88d6e3b079bff5ad8359ecdaeb42ab7d/
MAINTAINER= jihbed.research@gmail.com
HOMEPAGE= https://github.com/saullocastro/mapy
COMMENT= Modeling and Analysis in Python
LICENSE= modified-bsd
DEPENDS+= ${PYPKGPREFIX}-alg3dpy-0.16.0:../../wip/py-alg3dpy
USE_LANGUAGES= # none
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

152
py-mapy-package/PLIST Normal file
View File

@ -0,0 +1,152 @@
@comment $NetBSD$
${PYSITELIB}/mapy/__init__.py
${PYSITELIB}/mapy/__init__.pyo
${PYSITELIB}/mapy/__init__.pyc
${PYSITELIB}/mapy/constants.pyo
${PYSITELIB}/mapy/constants.pyc
${PYSITELIB}/mapy/fem.pyo
${PYSITELIB}/mapy/fem.pyc
${PYSITELIB}/mapy/constants.py
${PYSITELIB}/mapy/fem.py
${PYSITELIB}/mapy/model/__init__.py
${PYSITELIB}/mapy/model/__init__.pyo
${PYSITELIB}/mapy/model/__init__.pyc
${PYSITELIB}/mapy/model/coords.pyo
${PYSITELIB}/mapy/model/coords.pyc
${PYSITELIB}/mapy/model/grids.pyo
${PYSITELIB}/mapy/model/grids.pyc
${PYSITELIB}/mapy/model/constraints/__init__.py
${PYSITELIB}/mapy/model/constraints/__init__.pyo
${PYSITELIB}/mapy/model/constraints/__init__.pyc
${PYSITELIB}/mapy/model/coords.py
${PYSITELIB}/mapy/model/elements/__init__.py
${PYSITELIB}/mapy/model/elements/__init__.pyo
${PYSITELIB}/mapy/model/elements/__init__.pyc
${PYSITELIB}/mapy/model/elements/elem1d.pyo
${PYSITELIB}/mapy/model/elements/elem1d.pyc
${PYSITELIB}/mapy/model/elements/elem2d.pyo
${PYSITELIB}/mapy/model/elements/elem2d.pyc
${PYSITELIB}/mapy/model/elements/elem3d.pyo
${PYSITELIB}/mapy/model/elements/elem3d.pyc
${PYSITELIB}/mapy/model/elements/elembar.pyo
${PYSITELIB}/mapy/model/elements/elembar.pyc
${PYSITELIB}/mapy/model/elements/elemquad4.pyo
${PYSITELIB}/mapy/model/elements/elemquad4.pyc
${PYSITELIB}/mapy/model/elements/elemrod.pyo
${PYSITELIB}/mapy/model/elements/elemrod.pyc
${PYSITELIB}/mapy/model/elements/gauss_legendre.pyo
${PYSITELIB}/mapy/model/elements/gauss_legendre.pyc
${PYSITELIB}/mapy/model/elements/derivation_rotation_matrix.py
${PYSITELIB}/mapy/model/elements/elem1d.py
${PYSITELIB}/mapy/model/elements/elem2d.py
${PYSITELIB}/mapy/model/elements/elem3d.py
${PYSITELIB}/mapy/model/elements/elembar.py
${PYSITELIB}/mapy/model/elements/elemquad4.py
${PYSITELIB}/mapy/model/elements/elemrod.py
${PYSITELIB}/mapy/model/elements/elemtria/__init__.py
${PYSITELIB}/mapy/model/elements/elemtria/__init__.pyo
${PYSITELIB}/mapy/model/elements/elemtria/__init__.pyc
${PYSITELIB}/mapy/model/elements/elemtria/elemtria3.pyo
${PYSITELIB}/mapy/model/elements/elemtria/elemtria3.pyc
${PYSITELIB}/mapy/model/elements/elemtria/cst_equations.py
${PYSITELIB}/mapy/model/elements/elemtria/elemtria3.py
${PYSITELIB}/mapy/model/elements/gauss_legendre.py
${PYSITELIB}/mapy/model/grids.py
${PYSITELIB}/mapy/model/loads/__init__.py
${PYSITELIB}/mapy/model/loads/__init__.pyo
${PYSITELIB}/mapy/model/loads/__init__.pyc
${PYSITELIB}/mapy/model/loads/loads.pyo
${PYSITELIB}/mapy/model/loads/loads.pyc
${PYSITELIB}/mapy/model/loads/subcases.pyo
${PYSITELIB}/mapy/model/loads/subcases.pyc
${PYSITELIB}/mapy/model/loads/loads.py
${PYSITELIB}/mapy/model/loads/subcases.py
${PYSITELIB}/mapy/model/materials/__init__.py
${PYSITELIB}/mapy/model/materials/__init__.pyo
${PYSITELIB}/mapy/model/materials/__init__.pyc
${PYSITELIB}/mapy/model/materials/matiso.pyo
${PYSITELIB}/mapy/model/materials/matiso.pyc
${PYSITELIB}/mapy/model/materials/matlamina.pyo
${PYSITELIB}/mapy/model/materials/matlamina.pyc
${PYSITELIB}/mapy/model/materials/matiso.py
${PYSITELIB}/mapy/model/materials/matlamina.py
${PYSITELIB}/mapy/model/properties/__init__.py
${PYSITELIB}/mapy/model/properties/__init__.pyo
${PYSITELIB}/mapy/model/properties/__init__.pyc
${PYSITELIB}/mapy/model/properties/prop1d.pyo
${PYSITELIB}/mapy/model/properties/prop1d.pyc
${PYSITELIB}/mapy/model/properties/prop2d.pyo
${PYSITELIB}/mapy/model/properties/prop2d.pyc
${PYSITELIB}/mapy/model/properties/composite/__init__.py
${PYSITELIB}/mapy/model/properties/composite/__init__.pyo
${PYSITELIB}/mapy/model/properties/composite/__init__.pyc
${PYSITELIB}/mapy/model/properties/composite/pcomp.pyo
${PYSITELIB}/mapy/model/properties/composite/pcomp.pyc
${PYSITELIB}/mapy/model/properties/composite/lamina.py
${PYSITELIB}/mapy/model/properties/composite/laminate.py
${PYSITELIB}/mapy/model/properties/composite/pcomp.py
${PYSITELIB}/mapy/model/properties/prop1d.py
${PYSITELIB}/mapy/model/properties/prop2d.py
${PYSITELIB}/mapy/model/rebuild.py
${PYSITELIB}/mapy/modgen/__init__.py
${PYSITELIB}/mapy/modgen/__init__.pyo
${PYSITELIB}/mapy/modgen/__init__.pyc
${PYSITELIB}/mapy/modgen/cylinder/__init__.py
${PYSITELIB}/mapy/modgen/cylinder/__init__.pyo
${PYSITELIB}/mapy/modgen/cylinder/__init__.pyc
${PYSITELIB}/mapy/mplutils/__init__.py
${PYSITELIB}/mapy/mplutils/__init__.pyo
${PYSITELIB}/mapy/mplutils/__init__.pyc
${PYSITELIB}/mapy/mplutils/_big.pyo
${PYSITELIB}/mapy/mplutils/_big.pyc
${PYSITELIB}/mapy/mplutils/_small.pyo
${PYSITELIB}/mapy/mplutils/_small.pyc
${PYSITELIB}/mapy/mplutils/input_from_txt.pyo
${PYSITELIB}/mapy/mplutils/input_from_txt.pyc
${PYSITELIB}/mapy/mplutils/_big.py
${PYSITELIB}/mapy/mplutils/_small.py
${PYSITELIB}/mapy/mplutils/input_from_txt.py
${PYSITELIB}/mapy/mplutils/plot_defaults.py
${PYSITELIB}/mapy/reader/__init__.py
${PYSITELIB}/mapy/reader/__init__.pyo
${PYSITELIB}/mapy/reader/__init__.pyc
${PYSITELIB}/mapy/reader/cardtranslator.pyo
${PYSITELIB}/mapy/reader/cardtranslator.pyc
${PYSITELIB}/mapy/reader/input_reader.pyo
${PYSITELIB}/mapy/reader/input_reader.pyc
${PYSITELIB}/mapy/reader/cardtranslator.py
${PYSITELIB}/mapy/reader/input_reader.py
${PYSITELIB}/mapy/renderer/__init__.py
${PYSITELIB}/mapy/renderer/__init__.pyo
${PYSITELIB}/mapy/renderer/__init__.pyc
${PYSITELIB}/mapy/solver/__init__.py
${PYSITELIB}/mapy/solver/__init__.pyo
${PYSITELIB}/mapy/solver/__init__.pyc
${PYSITELIB}/mapy/solver/solver.pyo
${PYSITELIB}/mapy/solver/solver.pyc
${PYSITELIB}/mapy/solver/solver.py
${PYSITELIB}/mapy/sympytools/__init__.py
${PYSITELIB}/mapy/sympytools/__init__.pyo
${PYSITELIB}/mapy/sympytools/__init__.pyc
${PYSITELIB}/mapy/sympytools/denominator.pyo
${PYSITELIB}/mapy/sympytools/denominator.pyc
${PYSITELIB}/mapy/sympytools/mathematica_printer.pyo
${PYSITELIB}/mapy/sympytools/mathematica_printer.pyc
${PYSITELIB}/mapy/sympytools/matrixtools.pyo
${PYSITELIB}/mapy/sympytools/matrixtools.pyc
${PYSITELIB}/mapy/sympytools/denominator.py
${PYSITELIB}/mapy/sympytools/doperator.py
${PYSITELIB}/mapy/sympytools/mathematica_printer.py
${PYSITELIB}/mapy/sympytools/matrixtools.py
${PYSITELIB}/mapy/sympytools/voperator.py
${PYSITELIB}/mapy/sympytools/voperator2.py
${PYSITELIB}/mapy/version.py
${PYSITELIB}/mapy/writer/__init__.py
${PYSITELIB}/mapy/writer/__init__.pyo
${PYSITELIB}/mapy/writer/__init__.pyc
${PYSITELIB}/mapy/writer/abaqus.py
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt

7
py-mapy-package/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (mapy_package-0.15.0.tar.gz) = ceda4cc77d1d7725edb628197aa582637c487f63
RMD160 (mapy_package-0.15.0.tar.gz) = 896b89bb03e5f5d8ba41338bd51a40a45a5e4119
SHA512 (mapy_package-0.15.0.tar.gz) = 734790540ed973235c25b287ef30983850421f81043651b891d2ea5f3f3f4f7d636b4821ffabb7dbd5e6335713407904ff8f8415237b95d2e8e3b987de15f638
Size (mapy_package-0.15.0.tar.gz) = 41873 bytes
SHA1 (patch-setup.py) = 76fb0ffd22c66c50e2a362f89fb649b9e61cb571

View File

@ -0,0 +1,12 @@
$NetBSD$
--- setup.py.orig 2017-04-21 03:50:32.000000000 +0000
+++ setup.py
@@ -20,7 +20,6 @@ setup(
keywords = "finite element modeling analysis",
url = "https://github.com/saullocastro/mapy",
packages=find_packages(),
- long_description=read('README.md'),
classifiers=[
"Development Status :: 3 - Alpha",
"Topic :: Scientific/Engineering :: Mathematics",

10
py-tatsu/DESCR Normal file
View File

@ -0,0 +1,10 @@
TatSu (the successor to Grako) is a tool that takes grammars in a variation of
EBNF as input, and outputs memoizing (Packrat) PEG parsers in Python.
TatSu can compile a grammar stored in a string into a tatsu.grammars.Grammar
object that can be used to parse any given input, much like the re module does
with regular expressions, or it can generate a Python module that implements
the parser. TatSu has experimental support for left-recursive rules in PEG
grammars using the algorithm by Laurent and Mens. The generated AST has the
expected left associativity.

18
py-tatsu/Makefile Normal file
View File

@ -0,0 +1,18 @@
# $NetBSD$
DISTNAME= TatSu-4.3.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}
CATEGORIES= devel python
MASTER_SITES= https://files.pythonhosted.org/packages/8e/88/ec6d0364c15e568bbb77e1272ce5712ce5d0ed2f6fe0f057fe2d55d13608/
EXTRACT_SUFX= .zip
MAINTAINER= kamelderouiche@yahoo.com
HOMEPAGE= https://github.com/neogeny/tatsu
COMMENT= Python parsers from grammars in a variation of EBNF
LICENSE= modified-bsd
USE_LANGUAGES= c c++
.include "../../devel/py-cython/buildlink3.mk"
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

216
py-tatsu/PLIST Normal file
View File

@ -0,0 +1,216 @@
@comment $NetBSD$
bin/g2e
bin/tatsu
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/entry_points.txt
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/tatsu/__init__.py
${PYSITELIB}/tatsu/__init__.pyc
${PYSITELIB}/tatsu/__init__.pyo
${PYSITELIB}/tatsu/__main__.py
${PYSITELIB}/tatsu/__main__.pyc
${PYSITELIB}/tatsu/__main__.pyo
${PYSITELIB}/tatsu/_config.py
${PYSITELIB}/tatsu/_config.pyc
${PYSITELIB}/tatsu/_config.pyo
${PYSITELIB}/tatsu/_config.so
${PYSITELIB}/tatsu/_unicode_characters.py
${PYSITELIB}/tatsu/_unicode_characters.pyc
${PYSITELIB}/tatsu/_unicode_characters.pyo
${PYSITELIB}/tatsu/_unicode_characters.so
${PYSITELIB}/tatsu/_version.py
${PYSITELIB}/tatsu/_version.pyc
${PYSITELIB}/tatsu/_version.pyo
${PYSITELIB}/tatsu/_version.so
${PYSITELIB}/tatsu/ast.py
${PYSITELIB}/tatsu/ast.pyc
${PYSITELIB}/tatsu/ast.pyo
${PYSITELIB}/tatsu/ast.so
${PYSITELIB}/tatsu/bootstrap.py
${PYSITELIB}/tatsu/bootstrap.pyc
${PYSITELIB}/tatsu/bootstrap.pyo
${PYSITELIB}/tatsu/bootstrap.so
${PYSITELIB}/tatsu/buffering.py
${PYSITELIB}/tatsu/buffering.pyc
${PYSITELIB}/tatsu/buffering.pyo
${PYSITELIB}/tatsu/buffering.so
${PYSITELIB}/tatsu/codegen/__init__.py
${PYSITELIB}/tatsu/codegen/__init__.pyc
${PYSITELIB}/tatsu/codegen/__init__.pyo
${PYSITELIB}/tatsu/codegen/cgbase.py
${PYSITELIB}/tatsu/codegen/cgbase.pyc
${PYSITELIB}/tatsu/codegen/cgbase.pyo
${PYSITELIB}/tatsu/codegen/cgbase.so
${PYSITELIB}/tatsu/codegen/objectmodel.py
${PYSITELIB}/tatsu/codegen/objectmodel.pyc
${PYSITELIB}/tatsu/codegen/objectmodel.pyo
${PYSITELIB}/tatsu/codegen/objectmodel.so
${PYSITELIB}/tatsu/codegen/python.py
${PYSITELIB}/tatsu/codegen/python.pyc
${PYSITELIB}/tatsu/codegen/python.pyo
${PYSITELIB}/tatsu/codegen/python.so
${PYSITELIB}/tatsu/color.py
${PYSITELIB}/tatsu/color.pyc
${PYSITELIB}/tatsu/color.pyo
${PYSITELIB}/tatsu/color.so
${PYSITELIB}/tatsu/containers.py
${PYSITELIB}/tatsu/containers.pyc
${PYSITELIB}/tatsu/containers.pyo
${PYSITELIB}/tatsu/containers.so
${PYSITELIB}/tatsu/contexts.py
${PYSITELIB}/tatsu/contexts.pyc
${PYSITELIB}/tatsu/contexts.pyo
${PYSITELIB}/tatsu/contexts.so
${PYSITELIB}/tatsu/diagrams.py
${PYSITELIB}/tatsu/diagrams.pyc
${PYSITELIB}/tatsu/diagrams.pyo
${PYSITELIB}/tatsu/diagrams.so
${PYSITELIB}/tatsu/exceptions.py
${PYSITELIB}/tatsu/exceptions.pyc
${PYSITELIB}/tatsu/exceptions.pyo
${PYSITELIB}/tatsu/exceptions.so
${PYSITELIB}/tatsu/g2e/__init__.py
${PYSITELIB}/tatsu/g2e/__init__.pyc
${PYSITELIB}/tatsu/g2e/__init__.pyo
${PYSITELIB}/tatsu/g2e/__init__.so
${PYSITELIB}/tatsu/g2e/__main__.py
${PYSITELIB}/tatsu/g2e/__main__.pyc
${PYSITELIB}/tatsu/g2e/__main__.pyo
${PYSITELIB}/tatsu/g2e/__main__.so
${PYSITELIB}/tatsu/g2e/semantics.py
${PYSITELIB}/tatsu/g2e/semantics.pyc
${PYSITELIB}/tatsu/g2e/semantics.pyo
${PYSITELIB}/tatsu/g2e/semantics.so
${PYSITELIB}/tatsu/grammars.py
${PYSITELIB}/tatsu/grammars.pyc
${PYSITELIB}/tatsu/grammars.pyo
${PYSITELIB}/tatsu/grammars.so
${PYSITELIB}/tatsu/infos.py
${PYSITELIB}/tatsu/infos.pyc
${PYSITELIB}/tatsu/infos.pyo
${PYSITELIB}/tatsu/infos.so
${PYSITELIB}/tatsu/model.py
${PYSITELIB}/tatsu/model.pyc
${PYSITELIB}/tatsu/model.pyo
${PYSITELIB}/tatsu/model.so
${PYSITELIB}/tatsu/objectmodel.py
${PYSITELIB}/tatsu/objectmodel.pyc
${PYSITELIB}/tatsu/objectmodel.pyo
${PYSITELIB}/tatsu/objectmodel.so
${PYSITELIB}/tatsu/parser.py
${PYSITELIB}/tatsu/parser.pyc
${PYSITELIB}/tatsu/parser.pyo
${PYSITELIB}/tatsu/parser.so
${PYSITELIB}/tatsu/parser_semantics.py
${PYSITELIB}/tatsu/parser_semantics.pyc
${PYSITELIB}/tatsu/parser_semantics.pyo
${PYSITELIB}/tatsu/parser_semantics.so
${PYSITELIB}/tatsu/parsing.py
${PYSITELIB}/tatsu/parsing.pyc
${PYSITELIB}/tatsu/parsing.pyo
${PYSITELIB}/tatsu/parsing.so
${PYSITELIB}/tatsu/rendering.py
${PYSITELIB}/tatsu/rendering.pyc
${PYSITELIB}/tatsu/rendering.pyo
${PYSITELIB}/tatsu/rendering.so
${PYSITELIB}/tatsu/semantics.py
${PYSITELIB}/tatsu/semantics.pyc
${PYSITELIB}/tatsu/semantics.pyo
${PYSITELIB}/tatsu/semantics.so
${PYSITELIB}/tatsu/symtables.py
${PYSITELIB}/tatsu/symtables.pyc
${PYSITELIB}/tatsu/symtables.pyo
${PYSITELIB}/tatsu/symtables.so
${PYSITELIB}/tatsu/synth.py
${PYSITELIB}/tatsu/synth.pyc
${PYSITELIB}/tatsu/synth.pyo
${PYSITELIB}/tatsu/synth.so
${PYSITELIB}/tatsu/tool.py
${PYSITELIB}/tatsu/tool.pyc
${PYSITELIB}/tatsu/tool.pyo
${PYSITELIB}/tatsu/tool.so
${PYSITELIB}/tatsu/util.py
${PYSITELIB}/tatsu/util.pyc
${PYSITELIB}/tatsu/util.pyo
${PYSITELIB}/tatsu/util.so
${PYSITELIB}/tatsu/walkers.py
${PYSITELIB}/tatsu/walkers.pyc
${PYSITELIB}/tatsu/walkers.pyo
${PYSITELIB}/tatsu/walkers.so
${PYSITELIB}/tatsu/yaml.py
${PYSITELIB}/tatsu/yaml.pyc
${PYSITELIB}/tatsu/yaml.pyo
${PYSITELIB}/tatsu/yaml.so
${PYSITELIB}/test/__init__.py
${PYSITELIB}/test/__init__.pyc
${PYSITELIB}/test/__init__.pyo
${PYSITELIB}/test/__main__.py
${PYSITELIB}/test/__main__.pyc
${PYSITELIB}/test/__main__.pyo
${PYSITELIB}/test/ast_test.py
${PYSITELIB}/test/ast_test.pyc
${PYSITELIB}/test/ast_test.pyo
${PYSITELIB}/test/buffering_test.py
${PYSITELIB}/test/buffering_test.pyc
${PYSITELIB}/test/buffering_test.pyo
${PYSITELIB}/test/codegen_test.py
${PYSITELIB}/test/codegen_test.pyc
${PYSITELIB}/test/codegen_test.pyo
${PYSITELIB}/test/diagram_test.py
${PYSITELIB}/test/diagram_test.pyc
${PYSITELIB}/test/diagram_test.pyo
${PYSITELIB}/test/grammar/__init__.py
${PYSITELIB}/test/grammar/__init__.pyc
${PYSITELIB}/test/grammar/__init__.pyo
${PYSITELIB}/test/grammar/directive_test.py
${PYSITELIB}/test/grammar/directive_test.pyc
${PYSITELIB}/test/grammar/directive_test.pyo
${PYSITELIB}/test/grammar/join_test.py
${PYSITELIB}/test/grammar/join_test.pyc
${PYSITELIB}/test/grammar/join_test.pyo
${PYSITELIB}/test/grammar/keyword_test.py
${PYSITELIB}/test/grammar/keyword_test.pyc
${PYSITELIB}/test/grammar/keyword_test.pyo
${PYSITELIB}/test/grammar/left_recursion_test.py
${PYSITELIB}/test/grammar/left_recursion_test.pyc
${PYSITELIB}/test/grammar/left_recursion_test.pyo
${PYSITELIB}/test/grammar/lookahead_test.py
${PYSITELIB}/test/grammar/lookahead_test.pyc
${PYSITELIB}/test/grammar/lookahead_test.pyo
${PYSITELIB}/test/grammar/parameter_test.py
${PYSITELIB}/test/grammar/parameter_test.pyc
${PYSITELIB}/test/grammar/parameter_test.pyo
${PYSITELIB}/test/grammar/pattern_test.py
${PYSITELIB}/test/grammar/pattern_test.pyc
${PYSITELIB}/test/grammar/pattern_test.pyo
${PYSITELIB}/test/grammar/pretty_test.py
${PYSITELIB}/test/grammar/pretty_test.pyc
${PYSITELIB}/test/grammar/pretty_test.pyo
${PYSITELIB}/test/grammar/semantics_test.py
${PYSITELIB}/test/grammar/semantics_test.pyc
${PYSITELIB}/test/grammar/semantics_test.pyo
${PYSITELIB}/test/grammar/stateful_test.py
${PYSITELIB}/test/grammar/stateful_test.pyc
${PYSITELIB}/test/grammar/stateful_test.pyo
${PYSITELIB}/test/grammar/syntax_test.py
${PYSITELIB}/test/grammar/syntax_test.pyc
${PYSITELIB}/test/grammar/syntax_test.pyo
${PYSITELIB}/test/model_test.py
${PYSITELIB}/test/model_test.pyc
${PYSITELIB}/test/model_test.pyo
${PYSITELIB}/test/parsing_test.py
${PYSITELIB}/test/parsing_test.pyc
${PYSITELIB}/test/parsing_test.pyo
${PYSITELIB}/test/pickle_test.py
${PYSITELIB}/test/pickle_test.pyc
${PYSITELIB}/test/pickle_test.pyo
${PYSITELIB}/test/zzz_bootstrap/__init__.py
${PYSITELIB}/test/zzz_bootstrap/__init__.pyc
${PYSITELIB}/test/zzz_bootstrap/__init__.pyo
${PYSITELIB}/test/zzz_bootstrap/bootstrap_test.py
${PYSITELIB}/test/zzz_bootstrap/bootstrap_test.pyc
${PYSITELIB}/test/zzz_bootstrap/bootstrap_test.pyo

6
py-tatsu/distinfo Normal file
View File

@ -0,0 +1,6 @@
$NetBSD$
SHA1 (TatSu-4.3.0.zip) = f9827ea79eade7c67995ab407d506978dcac596a
RMD160 (TatSu-4.3.0.zip) = 0f6297d6bea1c8ffd775c8d14b66d1d791efef52
SHA512 (TatSu-4.3.0.zip) = 8c0d1cc6efeca737f3d373b32a1693a07cabe10ea2ea0e74aae9579ede61fd6d602cdf241c51d2fa9d35cf65110eb9b4d48d0741d618f062902841b9d29bb4cb
Size (TatSu-4.3.0.zip) = 130438 bytes

1
py-traces/DESCR Normal file
View File

@ -0,0 +1 @@
A library for unevenly-spaced time series analysis

19
py-traces/Makefile Normal file
View File

@ -0,0 +1,19 @@
# $NetBSD$
DISTNAME= traces-0.4.2
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= math python
MASTER_SITES= https://files.pythonhosted.org/packages/93/e8/dbdea1159fbbcc50e825e0ea9895c001fa1b2046a095619d33d83c243a9c/
MAINTAINER= jihbed.research@gmail.com
HOMEPAGE= https://github.com/datascopeanalytics/traces
COMMENT= Library for unevenly-spaced time series analysis
LICENSE= mit
DEPENDS+= ${PYPKGPREFIX}-pandas>=0.23.4:../../math/py-pandas
DEPENDS+= ${PYPKGPREFIX}-six>=1.12.0:../../lang/py-six
USE_LANGUAGES= # none
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

24
py-traces/PLIST Normal file
View File

@ -0,0 +1,24 @@
@comment $NetBSD$
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/traces/__init__.py
${PYSITELIB}/traces/__init__.pyo
${PYSITELIB}/traces/__init__.pyc
${PYSITELIB}/traces/decorators.pyo
${PYSITELIB}/traces/decorators.pyc
${PYSITELIB}/traces/histogram.pyo
${PYSITELIB}/traces/histogram.pyc
${PYSITELIB}/traces/operations.pyo
${PYSITELIB}/traces/operations.pyc
${PYSITELIB}/traces/timeseries.pyo
${PYSITELIB}/traces/timeseries.pyc
${PYSITELIB}/traces/utils.pyo
${PYSITELIB}/traces/utils.pyc
${PYSITELIB}/traces/decorators.py
${PYSITELIB}/traces/histogram.py
${PYSITELIB}/traces/operations.py
${PYSITELIB}/traces/timeseries.py
${PYSITELIB}/traces/utils.py

7
py-traces/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (traces-0.4.2.tar.gz) = 492713392fef467ea363729419b4f5e65c94004d
RMD160 (traces-0.4.2.tar.gz) = 3a618847aff659e7f2d0ee8d11b9f8925fb33519
SHA512 (traces-0.4.2.tar.gz) = b34a09a5940f19ae66bfaf0e6f8ae23f0810622097d4401e38238270edd3e2445ddd909cb16e3a25848ccc1447dd47f3c72bcf69665125db15dbe1f4a84e085e
Size (traces-0.4.2.tar.gz) = 137617 bytes
SHA1 (patch-setup.py) = c80088f3786d60d73d502fcf82ba5dcfeaf2b0ef

View File

@ -0,0 +1,18 @@
$NetBSD$
--- setup.py.orig 2018-11-27 23:49:28.000000000 +0000
+++ setup.py
@@ -59,13 +59,6 @@ setup(
packages=['traces'],
package_dir={'traces': 'traces'},
include_package_data=True,
- install_requires=read_dependencies('python.txt'),
- extras_require={
- 'test': read_dependencies('python-test.txt'),
- 'doc': read_dependencies('python-doc.txt'),
- 'dev': read_dependencies('python-dev.txt'),
- 'pandas': ['pandas'],
- },
license="MIT license",
zip_safe=False,
keywords='traces',