rawgl: import rawgl-0.2.1 as wip/rawgl

rawgl is a re-implementation of the engine used in the game Another World
(also known as Out of this World).

- Amiga and PC DOS releases (Bank*)
- 15th anniversary edition (Pak01.pak)
- 20th anniversary edition (game/*)
- Windows 3.1 release (Bank)
- 3DO release (GameData/*)
This commit is contained in:
Yorick Hardy 2019-12-18 08:58:27 +02:00
parent c68a143c2e
commit 4f3a497b24
6 changed files with 67 additions and 0 deletions

View File

@ -4244,6 +4244,7 @@ SUBDIR+= ratpoints
SUBDIR+= ratproxy
SUBDIR+= raw
SUBDIR+= rawdog
SUBDIR+= rawgl
SUBDIR+= rc.d.Interix
SUBDIR+= rclone
SUBDIR+= rdsn-git

10
rawgl/DESCR Normal file
View File

@ -0,0 +1,10 @@
rawgl is a re-implementation of the engine used in the game Another World
(also known as Out of this World).
## Supported Versions
- Amiga and PC DOS releases (Bank*)
- 15th anniversary edition (Pak01.pak)
- 20th anniversary edition (game/*)
- Windows 3.1 release (Bank)
- 3DO release (GameData/*)

30
rawgl/Makefile Normal file
View File

@ -0,0 +1,30 @@
# $NetBSD$
GITHUB_PROJECT= rawgl
GITHUB_TAG= rawgl-0.2.1
DISTNAME= rawgl-0.2.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GITHUB:=cyxx/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/cyxx/rawgl/
COMMENT= Re-implementation of the engine used in the game Another World
#LICENSE= # TODO: (see mk/license.mk)
WRKSRC= ${WRKDIR}/rawgl-rawgl-0.2.1
USE_LANGUAGES= c++
BUILD_TARGET= rawgl
INSTALLATION_DIRS= bin share/doc/rawgl
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rawgl ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/README.md \
${DESTDIR}${PREFIX}/share/doc/rawgl
.include "../../audio/SDL2_mixer/buildlink3.mk"
.include "../../devel/SDL2/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
rawgl/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD$
bin/rawgl
share/doc/rawgl/README.md

7
rawgl/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (rawgl-0.2.1.tar.gz) = b53b13be9013dd9834e86f54c16a08a917ce3525
RMD160 (rawgl-0.2.1.tar.gz) = 319517586e95c18fa679ad381aa46afb6a3786e6
SHA512 (rawgl-0.2.1.tar.gz) = 9f7fb55d375b38d7b05232250875c7174f52b6f9f390bdcbcad6866119525703036c99b56f6c5b09cddd6bbcfa67e364a24fe2d18bd69152f866f5e404e2cdc2
Size (rawgl-0.2.1.tar.gz) = 65404 bytes
SHA1 (patch-mixer.cpp) = e9ba0ed7da8d2684d693b32541f883525ceb87f8

View File

@ -0,0 +1,16 @@
$NetBSD$
Older SDL2_mixer used MIX_INIT_FLUIDSYNTH which has been renamed
to MIX_INIT_MID.
--- mixer.cpp.orig 2016-02-02 10:21:42.000000000 +0000
+++ mixer.cpp
@@ -53,7 +53,7 @@ struct Mixer_impl {
memset(_samples, 0, sizeof(_samples));
_music = 0;
- Mix_Init(MIX_INIT_OGG | MIX_INIT_FLUIDSYNTH);
+ Mix_Init(MIX_INIT_OGG | MIX_INIT_MID);
if (Mix_OpenAudio(kMixFreq, AUDIO_S16SYS, 2, kMixBufSize) < 0) {
warning("Mix_OpenAudio failed: %s", Mix_GetError());
}