wip/usbmuxd: import usbmuxd-1.1.0

A socket daemon to multiplex connections from and to iOS devices.
This commit is contained in:
Ryo ONODERA 2019-01-29 21:56:50 +09:00
parent c7c2bb3703
commit 942d29da5d
8 changed files with 95 additions and 0 deletions

1
usbmuxd/DESCR Normal file
View File

@ -0,0 +1 @@
A socket daemon to multiplex connections from and to iOS devices.

22
usbmuxd/Makefile Normal file
View File

@ -0,0 +1,22 @@
# $NetBSD$
DISTNAME= usbmuxd-1.1.0
CATEGORIES= comms
MASTER_SITES= http://www.libimobiledevice.org/downloads/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= ryoon@NetBSD.org
HOMEPAGE= http://www.libimobiledevice.org/
COMMENT= Multiplexing connections over USB for Apple iOS devices
LICENSE= gnu-gpl-v2 AND gnu-gpl-v3
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_TOOLS+= gmake pkg-config
.include "../../wip/libimobiledevice/buildlink3.mk"
.include "../../wip/libusbmuxd/buildlink3.mk"
.include "../../devel/libusb1/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../textproc/libplist/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
usbmuxd/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD$
man/man1/usbmuxd.1
sbin/usbmuxd

10
usbmuxd/distinfo Normal file
View File

@ -0,0 +1,10 @@
$NetBSD$
SHA1 (usbmuxd-1.1.0.tar.bz2) = a8f5d44b3014d57a6ae40960b56cc6f497876097
RMD160 (usbmuxd-1.1.0.tar.bz2) = cc690cd42a4699d9d464a94e3ab7433590123c5d
SHA512 (usbmuxd-1.1.0.tar.bz2) = 66aa0c40e912bf596b819098b87d88e9cf30b2e6352e607eeb778bd4f23bf9bb123fb6a6ecca2d4e4be3171e35d66200d632d2c9c80b1f2462bb45be8aa6912d
Size (usbmuxd-1.1.0.tar.bz2) = 321897 bytes
SHA1 (patch-Makefile.in) = 2d5a800ca6f098fc4c8a2eb21cb75c130407f09f
SHA1 (patch-configure) = d833ffadd5eee3482bacd841aded1bb37b368c1b
SHA1 (patch-configure.ac) = cd4457924ba71c414e8537a1ab563ca2d2664d3e
SHA1 (patch-src_main.c) = 57323e5fb532e891d88c0a469219b5a71c0a6adb

View File

@ -0,0 +1,14 @@
$NetBSD$
* Disable udev installation
--- Makefile.in.orig 2014-10-17 20:27:41.000000000 +0000
+++ Makefile.in
@@ -264,7 +264,6 @@ SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
STRIP = @STRIP@
SYSTEMD_SUB = @SYSTEMD_SUB@
-UDEV_SUB = @UDEV_SUB@
VERSION = @VERSION@
WINDRES = @WINDRES@
abs_builddir = @abs_builddir@

View File

@ -0,0 +1,15 @@
$NetBSD$
* POSIX shell portability
--- configure.orig 2014-10-17 20:27:41.000000000 +0000
+++ configure
@@ -15826,7 +15826,7 @@ $as_echo "#define HAVE_LIBIMOBILEDEVICE
fi
else
- if test "x$with_preflight" == "xyes"; then
+ if test "x$with_preflight" = "xyes"; then
as_fn_error $? "preflight worker support requested but libimobiledevice could not be found" "$LINENO" 5
fi
fi

View File

@ -0,0 +1,15 @@
$NetBSD$
* POSIX shell portability
--- configure.ac.orig 2014-10-17 20:27:35.000000000 +0000
+++ configure.ac
@@ -37,7 +37,7 @@ if test "x$have_limd" = "xyes"; then
AC_SUBST(libimobiledevice_LIBS)
fi
else
- if test "x$with_preflight" == "xyes"; then
+ if test "x$with_preflight" = "xyes"; then
AC_MSG_ERROR([preflight worker support requested but libimobiledevice could not be found])
fi
fi

View File

@ -0,0 +1,15 @@
$NetBSD$
* Support NetBSD
--- src/main.c.orig 2014-10-16 13:17:48.000000000 +0000
+++ src/main.c
@@ -150,7 +150,7 @@ static void set_signal_handlers(void)
sigaction(SIGUSR2, &sa, NULL);
}
-#if defined(__FreeBSD__) || defined(__APPLE__)
+#if defined(__FreeBSD__) || defined(__APPLE__) || defined(__NetBSD__)
static int ppoll(struct pollfd *fds, nfds_t nfds, const struct timespec *timeout, const sigset_t *sigmask)
{
int ready;