libvirt: add version 5.8.0

libvirt is:
+ A toolkit to interact with the virtualization capabilities of recent
  versions of operating systems, see our project goals for details.
+ A long term stable C API
+ A set of bindings for common languages
+ A CIM provider for the DMTF virtualization schema
+ A QMF agent for the AMQP/QPid messaging system
libvirt supports:
+ The KVM/QEMU Linux hypervisor
+ The Xen hypervisor
+ The LXC Linux container system
+ The OpenVZ Linux container system
+ The User Mode Linux paravirtualized kernel
+ The VirtualBox hypervisor
+ The VMware ESX and GSX hypervisors
+ The VMware Workstation and Player hypervisors
+ Virtual networks using bridging, NAT, VEPA and VN-LINK.
+ Storage on IDE/SCSI/USB disks, FibreChannel, LVM, iSCSI, NFS and filesystems
libvirt provides:
+ Remote management using TLS encryption and x509 certificates
+ Remote management authenticating with Kerberos and SASL
+ Local access control using PolicyKit
+ Zero-conf discovery using Avahi multicast-DNS
+ Management of virtual machines, virtual networks and storage
This commit is contained in:
Maya Rashish 2019-10-20 10:28:08 +03:00
parent 7a75f06f25
commit a8ff750707
11 changed files with 722 additions and 0 deletions

24
libvirt/DESCR Normal file
View File

@ -0,0 +1,24 @@
libvirt is:
+ A toolkit to interact with the virtualization capabilities of recent
versions of operating systems, see our project goals for details.
+ A long term stable C API
+ A set of bindings for common languages
+ A CIM provider for the DMTF virtualization schema
+ A QMF agent for the AMQP/QPid messaging system
libvirt supports:
+ The KVM/QEMU Linux hypervisor
+ The Xen hypervisor
+ The LXC Linux container system
+ The OpenVZ Linux container system
+ The User Mode Linux paravirtualized kernel
+ The VirtualBox hypervisor
+ The VMware ESX and GSX hypervisors
+ The VMware Workstation and Player hypervisors
+ Virtual networks using bridging, NAT, VEPA and VN-LINK.
+ Storage on IDE/SCSI/USB disks, FibreChannel, LVM, iSCSI, NFS and filesystems
libvirt provides:
+ Remote management using TLS encryption and x509 certificates
+ Remote management authenticating with Kerberos and SASL
+ Local access control using PolicyKit
+ Zero-conf discovery using Avahi multicast-DNS
+ Management of virtual machines, virtual networks and storage

51
libvirt/Makefile Normal file
View File

@ -0,0 +1,51 @@
# $NetBSD: Makefile,v 1.68 2019/09/02 13:20:09 adam Exp $
DISTNAME= libvirt-5.8.0
CATEGORIES= sysutils
MASTER_SITES= http://libvirt.org/sources/
EXTRACT_SUFX= .tar.xz
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://libvirt.org/
COMMENT= Virtualisation toolkit for host operating systems
LICENSE= gnu-lgpl-v2
USE_TOOLS+= gmake perl pkg-config
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
BUILD_DEFS+= VARBASE
CONFIGURE_ARGS+= --sysconfdir=${EGDIR} --localstatedir=${VARBASE}
TEST_TARGET= check
RCD_SCRIPTS= libvirtd
SUBST_CLASSES+= reserved-name
SUBST_STAGE.reserved-name= pre-configure
SUBST_FILES.reserved-name= src/qemu/qemu_process.h src/qemu/qemu_process.c
SUBST_SED.reserved-name= -e 's|stderr|qemu_stderr|g'
PKGCONFIG_OVERRIDE+= libvirt.pc.in
PKGCONFIG_OVERRIDE+= libvirt-admin.pc.in
PKGCONFIG_OVERRIDE+= libvirt-lxc.pc.in
PKGCONFIG_OVERRIDE+= libvirt-qemu.pc.in
AUTO_MKDIRS= yes
EGDIR= ${PREFIX}/share/examples
CONF_FILES+= ${EGDIR}/libvirt/libvirt-admin.conf ${PKG_SYSCONFDIR}/libvirt/libvirt-admin.conf
CONF_FILES+= ${EGDIR}/libvirt/libvirt.conf ${PKG_SYSCONFDIR}/libvirt/libvirt.conf
CONF_FILES+= ${EGDIR}/libvirt/libvirtd.conf ${PKG_SYSCONFDIR}/libvirt/libvirtd.conf
CONF_FILES+= ${EGDIR}/libvirt/qemu/networks/autostart/default.xml ${PKG_SYSCONFDIR}/libvirt/qemu/networks/autostart/default.xml
CONF_FILES+= ${EGDIR}/libvirt/qemu/networks/default.xml ${PKG_SYSCONFDIR}/libvirt/qemu/networks/default.xml
CONF_FILES+= ${EGDIR}/libvirt/virtlockd.conf ${PKG_SYSCONFDIR}/libvirt/virtlockd.conf
CONF_FILES+= ${EGDIR}/libvirt/virtlogd.conf ${PKG_SYSCONFDIR}/libvirt/virtlogd.conf
CONF_FILES+= ${EGDIR}/logrotate.d/libvirtd ${PKG_SYSCONFDIR}/libvirtlogrotate.d/libvirtd
CONF_FILES+= ${EGDIR}/logrotate.d/libvirtd.libxl ${PKG_SYSCONFDIR}/libvirtlogrotate.d/libvirtd.libxl
CONF_FILES+= ${EGDIR}/logrotate.d/libvirtd.lxc ${PKG_SYSCONFDIR}/libvirtlogrotate.d/libvirtd.lxc
CONF_FILES+= ${EGDIR}/logrotate.d/libvirtd.qemu ${PKG_SYSCONFDIR}/libvirtlogrotate.d/libvirtd.qemu
CONFIGURE_ARGS.NetBSD+= --with-qemu-group=wheel
.include "../../devel/yajl/buildlink3.mk"
.include "../../security/gnutls/buildlink3.mk"
.include "../../net/libpcap/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

513
libvirt/PLIST Normal file
View File

@ -0,0 +1,513 @@
@comment $NetBSD$
bin/virsh
bin/virt-admin
bin/virt-host-validate
bin/virt-pki-validate
bin/virt-xml-validate
include/libvirt/libvirt-admin.h
include/libvirt/libvirt-common.h
include/libvirt/libvirt-domain-checkpoint.h
include/libvirt/libvirt-domain-snapshot.h
include/libvirt/libvirt-domain.h
include/libvirt/libvirt-event.h
include/libvirt/libvirt-host.h
include/libvirt/libvirt-interface.h
include/libvirt/libvirt-lxc.h
include/libvirt/libvirt-network.h
include/libvirt/libvirt-nodedev.h
include/libvirt/libvirt-nwfilter.h
include/libvirt/libvirt-qemu.h
include/libvirt/libvirt-secret.h
include/libvirt/libvirt-storage.h
include/libvirt/libvirt-stream.h
include/libvirt/libvirt.h
include/libvirt/virterror.h
lib/libvirt-admin.la
lib/libvirt-lxc.la
lib/libvirt-qemu.la
lib/libvirt.la
lib/libvirt/connection-driver/libvirt_driver_network.la
lib/libvirt/connection-driver/libvirt_driver_qemu.la
lib/libvirt/connection-driver/libvirt_driver_secret.la
lib/libvirt/connection-driver/libvirt_driver_storage.la
lib/libvirt/connection-driver/libvirt_driver_vbox.la
lib/libvirt/lock-driver/lockd.la
lib/libvirt/storage-backend/libvirt_storage_backend_fs.la
lib/libvirt/storage-backend/libvirt_storage_backend_zfs.la
lib/libvirt/storage-file/libvirt_storage_file_fs.la
lib/pkgconfig/libvirt-admin.pc
lib/pkgconfig/libvirt-lxc.pc
lib/pkgconfig/libvirt-qemu.pc
lib/pkgconfig/libvirt.pc
libexec/libvirt-guests.sh
libexec/libvirt_iohelper
libexec/libvirt_leaseshelper
man/man1/virsh.1
man/man1/virt-admin.1
man/man1/virt-host-validate.1
man/man1/virt-pki-validate.1
man/man1/virt-xml-validate.1
man/man7/virkeycode-atset1.7
man/man7/virkeycode-atset2.7
man/man7/virkeycode-atset3.7
man/man7/virkeycode-linux.7
man/man7/virkeycode-osx.7
man/man7/virkeycode-qnum.7
man/man7/virkeycode-usb.7
man/man7/virkeycode-win32.7
man/man7/virkeycode-xtkbd.7
man/man7/virkeyname-linux.7
man/man7/virkeyname-osx.7
man/man7/virkeyname-win32.7
man/man8/libvirtd.8
man/man8/virtlockd.8
man/man8/virtlogd.8
sbin/libvirtd
sbin/virtlockd
sbin/virtlogd
sbin/virtnetworkd
sbin/virtproxyd
sbin/virtqemud
sbin/virtsecretd
sbin/virtstoraged
sbin/virtvboxd
share/augeas/lenses/libvirt_lockd.aug
share/augeas/lenses/libvirtd.aug
share/augeas/lenses/libvirtd_qemu.aug
share/augeas/lenses/tests/test_libvirt_lockd.aug
share/augeas/lenses/tests/test_libvirtd.aug
share/augeas/lenses/tests/test_libvirtd_qemu.aug
share/augeas/lenses/tests/test_virtlockd.aug
share/augeas/lenses/tests/test_virtlogd.aug
share/augeas/lenses/tests/test_virtnetworkd.aug
share/augeas/lenses/tests/test_virtproxyd.aug
share/augeas/lenses/tests/test_virtqemud.aug
share/augeas/lenses/tests/test_virtsecretd.aug
share/augeas/lenses/tests/test_virtstoraged.aug
share/augeas/lenses/tests/test_virtvboxd.aug
share/augeas/lenses/virtlockd.aug
share/augeas/lenses/virtlogd.aug
share/augeas/lenses/virtnetworkd.aug
share/augeas/lenses/virtproxyd.aug
share/augeas/lenses/virtqemud.aug
share/augeas/lenses/virtsecretd.aug
share/augeas/lenses/virtstoraged.aug
share/augeas/lenses/virtvboxd.aug
share/doc/libvirt/examples/c/admin/client_close.c
share/doc/libvirt/examples/c/admin/client_info.c
share/doc/libvirt/examples/c/admin/client_limits.c
share/doc/libvirt/examples/c/admin/list_clients.c
share/doc/libvirt/examples/c/admin/list_servers.c
share/doc/libvirt/examples/c/admin/logging.c
share/doc/libvirt/examples/c/admin/threadpool_params.c
share/doc/libvirt/examples/c/domain/dommigrate.c
share/doc/libvirt/examples/c/domain/domtop.c
share/doc/libvirt/examples/c/domain/info1.c
share/doc/libvirt/examples/c/domain/rename.c
share/doc/libvirt/examples/c/domain/suspend.c
share/doc/libvirt/examples/c/misc/event-test.c
share/doc/libvirt/examples/c/misc/hellolibvirt.c
share/doc/libvirt/examples/c/misc/openauth.c
share/doc/libvirt/examples/polkit/libvirt-acl.rules
share/doc/libvirt/examples/sh/virt-lxc-convert
share/doc/libvirt/examples/systemtap/events.stp
share/doc/libvirt/examples/systemtap/lock-debug.stp
share/doc/libvirt/examples/systemtap/qemu-monitor.stp
share/doc/libvirt/examples/systemtap/rpc-monitor.stp
share/doc/libvirt/examples/xml/storage/pool-dir.xml
share/doc/libvirt/examples/xml/storage/pool-fs.xml
share/doc/libvirt/examples/xml/storage/pool-logical.xml
share/doc/libvirt/examples/xml/storage/pool-netfs.xml
share/doc/libvirt/examples/xml/storage/vol-cow.xml
share/doc/libvirt/examples/xml/storage/vol-qcow.xml
share/doc/libvirt/examples/xml/storage/vol-qcow2.xml
share/doc/libvirt/examples/xml/storage/vol-raw.xml
share/doc/libvirt/examples/xml/storage/vol-sparse.xml
share/doc/libvirt/examples/xml/storage/vol-vmdk.xml
share/doc/libvirt/examples/xml/test/testdev.xml
share/doc/libvirt/examples/xml/test/testdomfc4.xml
share/doc/libvirt/examples/xml/test/testdomfv0.xml
share/doc/libvirt/examples/xml/test/testnetdef.xml
share/doc/libvirt/examples/xml/test/testnetpriv.xml
share/doc/libvirt/examples/xml/test/testnode.xml
share/doc/libvirt/examples/xml/test/testnodeinline.xml
share/doc/libvirt/examples/xml/test/testpool.xml
share/doc/libvirt/examples/xml/test/testvol.xml
share/doc/libvirt/html/32favicon.png
share/doc/libvirt/html/404.html
share/doc/libvirt/html/acl.html
share/doc/libvirt/html/aclpolkit.html
share/doc/libvirt/html/api.html
share/doc/libvirt/html/api_extension.html
share/doc/libvirt/html/apps.html
share/doc/libvirt/html/architecture.gif
share/doc/libvirt/html/architecture.html
share/doc/libvirt/html/auditlog.html
share/doc/libvirt/html/auth.html
share/doc/libvirt/html/bindings.html
share/doc/libvirt/html/bugs.html
share/doc/libvirt/html/cgroups.html
share/doc/libvirt/html/compiling.html
share/doc/libvirt/html/contact.html
share/doc/libvirt/html/contribute.html
share/doc/libvirt/html/csharp.html
share/doc/libvirt/html/dbus.html
share/doc/libvirt/html/devguide.html
share/doc/libvirt/html/docs.html
share/doc/libvirt/html/downloads.html
share/doc/libvirt/html/drivers.html
share/doc/libvirt/html/drvbhyve.html
share/doc/libvirt/html/drvesx.html
share/doc/libvirt/html/drvhyperv.html
share/doc/libvirt/html/drvlxc.html
share/doc/libvirt/html/drvnodedev.html
share/doc/libvirt/html/drvopenvz.html
share/doc/libvirt/html/drvphyp.html
share/doc/libvirt/html/drvqemu.html
share/doc/libvirt/html/drvremote.html
share/doc/libvirt/html/drvtest.html
share/doc/libvirt/html/drvvbox.html
share/doc/libvirt/html/drvvirtuozzo.html
share/doc/libvirt/html/drvvmware.html
share/doc/libvirt/html/drvxen.html
share/doc/libvirt/html/errors.html
share/doc/libvirt/html/firewall.html
share/doc/libvirt/html/fonts/LICENSE.md
share/doc/libvirt/html/fonts/overpass-bold-italic.woff
share/doc/libvirt/html/fonts/overpass-bold.woff
share/doc/libvirt/html/fonts/overpass-italic.woff
share/doc/libvirt/html/fonts/overpass-light-italic.woff
share/doc/libvirt/html/fonts/overpass-light.woff
share/doc/libvirt/html/fonts/overpass-mono-bold.woff
share/doc/libvirt/html/fonts/overpass-mono-light.woff
share/doc/libvirt/html/fonts/overpass-mono-regular.woff
share/doc/libvirt/html/fonts/overpass-mono-semibold.woff
share/doc/libvirt/html/fonts/overpass-regular.woff
share/doc/libvirt/html/fonts/stylesheet.css
share/doc/libvirt/html/format.html
share/doc/libvirt/html/formatcaps.html
share/doc/libvirt/html/formatcheckpoint.html
share/doc/libvirt/html/formatdomain.html
share/doc/libvirt/html/formatdomaincaps.html
share/doc/libvirt/html/formatnetwork.html
share/doc/libvirt/html/formatnetworkport.html
share/doc/libvirt/html/formatnode.html
share/doc/libvirt/html/formatnwfilter.html
share/doc/libvirt/html/formatsecret.html
share/doc/libvirt/html/formatsnapshot.html
share/doc/libvirt/html/formatstorage.html
share/doc/libvirt/html/formatstoragecaps.html
share/doc/libvirt/html/formatstorageencryption.html
share/doc/libvirt/html/generic.css
share/doc/libvirt/html/goals.html
share/doc/libvirt/html/governance.html
share/doc/libvirt/html/hacking.html
share/doc/libvirt/html/hooks.html
share/doc/libvirt/html/html/home.png
share/doc/libvirt/html/html/index.html
share/doc/libvirt/html/html/left.png
share/doc/libvirt/html/html/libvirt-libvirt-common.html
share/doc/libvirt/html/html/libvirt-libvirt-domain-checkpoint.html
share/doc/libvirt/html/html/libvirt-libvirt-domain-snapshot.html
share/doc/libvirt/html/html/libvirt-libvirt-domain.html
share/doc/libvirt/html/html/libvirt-libvirt-event.html
share/doc/libvirt/html/html/libvirt-libvirt-host.html
share/doc/libvirt/html/html/libvirt-libvirt-interface.html
share/doc/libvirt/html/html/libvirt-libvirt-network.html
share/doc/libvirt/html/html/libvirt-libvirt-nodedev.html
share/doc/libvirt/html/html/libvirt-libvirt-nwfilter.html
share/doc/libvirt/html/html/libvirt-libvirt-secret.html
share/doc/libvirt/html/html/libvirt-libvirt-storage.html
share/doc/libvirt/html/html/libvirt-libvirt-stream.html
share/doc/libvirt/html/html/libvirt-virterror.html
share/doc/libvirt/html/html/right.png
share/doc/libvirt/html/html/up.png
share/doc/libvirt/html/hvsupport.html
share/doc/libvirt/html/index.html
share/doc/libvirt/html/internals.html
share/doc/libvirt/html/internals/command.html
share/doc/libvirt/html/internals/eventloop.html
share/doc/libvirt/html/internals/locking.html
share/doc/libvirt/html/internals/rpc.html
share/doc/libvirt/html/java.html
share/doc/libvirt/html/js/main.js
share/doc/libvirt/html/kbase.html
share/doc/libvirt/html/kbase/domainstatecapture.html
share/doc/libvirt/html/kbase/launch_security_sev.html
share/doc/libvirt/html/kbase/locking-lockd.html
share/doc/libvirt/html/kbase/locking-sanlock.html
share/doc/libvirt/html/kbase/locking.html
share/doc/libvirt/html/kbase/secureusage.html
share/doc/libvirt/html/libvirt-daemon-arch.png
share/doc/libvirt/html/libvirt-driver-arch.png
share/doc/libvirt/html/libvirt-object-model.png
share/doc/libvirt/html/libvirt.css
share/doc/libvirt/html/logging.html
share/doc/libvirt/html/logos/logo-banner-dark-256.png
share/doc/libvirt/html/logos/logo-banner-dark-800.png
share/doc/libvirt/html/logos/logo-banner-dark.svg
share/doc/libvirt/html/logos/logo-banner-light-256.png
share/doc/libvirt/html/logos/logo-banner-light-800.png
share/doc/libvirt/html/logos/logo-banner-light.svg
share/doc/libvirt/html/logos/logo-base.svg
share/doc/libvirt/html/logos/logo-square-128.png
share/doc/libvirt/html/logos/logo-square-192.png
share/doc/libvirt/html/logos/logo-square-256.png
share/doc/libvirt/html/logos/logo-square-96.png
share/doc/libvirt/html/logos/logo-square-powered-128.png
share/doc/libvirt/html/logos/logo-square-powered-192.png
share/doc/libvirt/html/logos/logo-square-powered-256.png
share/doc/libvirt/html/logos/logo-square-powered-96.png
share/doc/libvirt/html/logos/logo-square-powered.svg
share/doc/libvirt/html/logos/logo-square.svg
share/doc/libvirt/html/main.css
share/doc/libvirt/html/migration-managed-direct.png
share/doc/libvirt/html/migration-managed-p2p.png
share/doc/libvirt/html/migration-native.png
share/doc/libvirt/html/migration-tunnel.png
share/doc/libvirt/html/migration-unmanaged-direct.png
share/doc/libvirt/html/migration.html
share/doc/libvirt/html/mobile.css
share/doc/libvirt/html/news-2005.html
share/doc/libvirt/html/news-2006.html
share/doc/libvirt/html/news-2007.html
share/doc/libvirt/html/news-2008.html
share/doc/libvirt/html/news-2009.html
share/doc/libvirt/html/news-2010.html
share/doc/libvirt/html/news-2011.html
share/doc/libvirt/html/news-2012.html
share/doc/libvirt/html/news-2013.html
share/doc/libvirt/html/news-2014.html
share/doc/libvirt/html/news-2015.html
share/doc/libvirt/html/news-2016.html
share/doc/libvirt/html/news.html
share/doc/libvirt/html/node.gif
share/doc/libvirt/html/nss.html
share/doc/libvirt/html/pci-hotplug.html
share/doc/libvirt/html/php.html
share/doc/libvirt/html/platforms.html
share/doc/libvirt/html/python.html
share/doc/libvirt/html/remote.html
share/doc/libvirt/html/securityprocess.html
share/doc/libvirt/html/storage.html
share/doc/libvirt/html/strategy.html
share/doc/libvirt/html/support.html
share/doc/libvirt/html/testapi.html
share/doc/libvirt/html/testsuites.html
share/doc/libvirt/html/testtck.html
share/doc/libvirt/html/todo.html
share/doc/libvirt/html/uri.html
share/doc/libvirt/html/virshcmdref.html
share/doc/libvirt/html/windows.html
share/examples/libvirt/libvirt-admin.conf
share/examples/libvirt/libvirt.conf
share/examples/libvirt/libvirtd.conf
share/examples/libvirt/qemu-lockd.conf
share/examples/libvirt/qemu.conf
share/examples/libvirt/qemu/networks/autostart/default.xml
share/examples/libvirt/qemu/networks/default.xml
share/examples/libvirt/virtlockd.conf
share/examples/libvirt/virtlogd.conf
share/examples/libvirt/virtnetworkd.conf
share/examples/libvirt/virtproxyd.conf
share/examples/libvirt/virtqemud.conf
share/examples/libvirt/virtsecretd.conf
share/examples/libvirt/virtstoraged.conf
share/examples/libvirt/virtvboxd.conf
share/examples/logrotate.d/libvirtd
share/examples/logrotate.d/libvirtd.libxl
share/examples/logrotate.d/libvirtd.lxc
share/examples/logrotate.d/libvirtd.qemu
share/libvirt/api/libvirt-admin-api.xml
share/libvirt/api/libvirt-api.xml
share/libvirt/api/libvirt-lxc-api.xml
share/libvirt/api/libvirt-qemu-api.xml
share/libvirt/cpu_map/index.xml
share/libvirt/cpu_map/ppc64_POWER6.xml
share/libvirt/cpu_map/ppc64_POWER7.xml
share/libvirt/cpu_map/ppc64_POWER8.xml
share/libvirt/cpu_map/ppc64_POWER9.xml
share/libvirt/cpu_map/ppc64_POWERPC_e5500.xml
share/libvirt/cpu_map/ppc64_POWERPC_e6500.xml
share/libvirt/cpu_map/ppc64_vendors.xml
share/libvirt/cpu_map/x86_486.xml
share/libvirt/cpu_map/x86_Broadwell-IBRS.xml
share/libvirt/cpu_map/x86_Broadwell-noTSX-IBRS.xml
share/libvirt/cpu_map/x86_Broadwell-noTSX.xml
share/libvirt/cpu_map/x86_Broadwell.xml
share/libvirt/cpu_map/x86_Cascadelake-Server.xml
share/libvirt/cpu_map/x86_Conroe.xml
share/libvirt/cpu_map/x86_EPYC-IBPB.xml
share/libvirt/cpu_map/x86_EPYC.xml
share/libvirt/cpu_map/x86_Haswell-IBRS.xml
share/libvirt/cpu_map/x86_Haswell-noTSX-IBRS.xml
share/libvirt/cpu_map/x86_Haswell-noTSX.xml
share/libvirt/cpu_map/x86_Haswell.xml
share/libvirt/cpu_map/x86_Icelake-Client.xml
share/libvirt/cpu_map/x86_Icelake-Server.xml
share/libvirt/cpu_map/x86_IvyBridge-IBRS.xml
share/libvirt/cpu_map/x86_IvyBridge.xml
share/libvirt/cpu_map/x86_Nehalem-IBRS.xml
share/libvirt/cpu_map/x86_Nehalem.xml
share/libvirt/cpu_map/x86_Opteron_G1.xml
share/libvirt/cpu_map/x86_Opteron_G2.xml
share/libvirt/cpu_map/x86_Opteron_G3.xml
share/libvirt/cpu_map/x86_Opteron_G4.xml
share/libvirt/cpu_map/x86_Opteron_G5.xml
share/libvirt/cpu_map/x86_Penryn.xml
share/libvirt/cpu_map/x86_SandyBridge-IBRS.xml
share/libvirt/cpu_map/x86_SandyBridge.xml
share/libvirt/cpu_map/x86_Skylake-Client-IBRS.xml
share/libvirt/cpu_map/x86_Skylake-Client.xml
share/libvirt/cpu_map/x86_Skylake-Server-IBRS.xml
share/libvirt/cpu_map/x86_Skylake-Server.xml
share/libvirt/cpu_map/x86_Westmere-IBRS.xml
share/libvirt/cpu_map/x86_Westmere.xml
share/libvirt/cpu_map/x86_athlon.xml
share/libvirt/cpu_map/x86_core2duo.xml
share/libvirt/cpu_map/x86_coreduo.xml
share/libvirt/cpu_map/x86_cpu64-rhel5.xml
share/libvirt/cpu_map/x86_cpu64-rhel6.xml
share/libvirt/cpu_map/x86_features.xml
share/libvirt/cpu_map/x86_kvm32.xml
share/libvirt/cpu_map/x86_kvm64.xml
share/libvirt/cpu_map/x86_n270.xml
share/libvirt/cpu_map/x86_pentium.xml
share/libvirt/cpu_map/x86_pentium2.xml
share/libvirt/cpu_map/x86_pentium3.xml
share/libvirt/cpu_map/x86_pentiumpro.xml
share/libvirt/cpu_map/x86_phenom.xml
share/libvirt/cpu_map/x86_qemu32.xml
share/libvirt/cpu_map/x86_qemu64.xml
share/libvirt/cpu_map/x86_vendors.xml
share/libvirt/schemas/basictypes.rng
share/libvirt/schemas/capability.rng
share/libvirt/schemas/cputypes.rng
share/libvirt/schemas/domain.rng
share/libvirt/schemas/domaincaps.rng
share/libvirt/schemas/domaincheckpoint.rng
share/libvirt/schemas/domaincommon.rng
share/libvirt/schemas/domainsnapshot.rng
share/libvirt/schemas/interface.rng
share/libvirt/schemas/network.rng
share/libvirt/schemas/networkcommon.rng
share/libvirt/schemas/networkport.rng
share/libvirt/schemas/nodedev.rng
share/libvirt/schemas/nwfilter.rng
share/libvirt/schemas/nwfilter_params.rng
share/libvirt/schemas/nwfilterbinding.rng
share/libvirt/schemas/secret.rng
share/libvirt/schemas/storagecommon.rng
share/libvirt/schemas/storagepool.rng
share/libvirt/schemas/storagepoolcaps.rng
share/libvirt/schemas/storagevol.rng
share/libvirt/test-screenshot.png
share/locale/af/LC_MESSAGES/libvirt.mo
share/locale/am/LC_MESSAGES/libvirt.mo
share/locale/anp/LC_MESSAGES/libvirt.mo
share/locale/ar/LC_MESSAGES/libvirt.mo
share/locale/as/LC_MESSAGES/libvirt.mo
share/locale/ast/LC_MESSAGES/libvirt.mo
share/locale/bal/LC_MESSAGES/libvirt.mo
share/locale/be/LC_MESSAGES/libvirt.mo
share/locale/bg/LC_MESSAGES/libvirt.mo
share/locale/bn/LC_MESSAGES/libvirt.mo
share/locale/bn_IN/LC_MESSAGES/libvirt.mo
share/locale/bo/LC_MESSAGES/libvirt.mo
share/locale/br/LC_MESSAGES/libvirt.mo
share/locale/brx/LC_MESSAGES/libvirt.mo
share/locale/bs/LC_MESSAGES/libvirt.mo
share/locale/ca/LC_MESSAGES/libvirt.mo
share/locale/cs/LC_MESSAGES/libvirt.mo
share/locale/cy/LC_MESSAGES/libvirt.mo
share/locale/da/LC_MESSAGES/libvirt.mo
share/locale/de/LC_MESSAGES/libvirt.mo
share/locale/de_CH/LC_MESSAGES/libvirt.mo
share/locale/el/LC_MESSAGES/libvirt.mo
share/locale/en_GB/LC_MESSAGES/libvirt.mo
share/locale/eo/LC_MESSAGES/libvirt.mo
share/locale/es/LC_MESSAGES/libvirt.mo
share/locale/et/LC_MESSAGES/libvirt.mo
share/locale/eu/LC_MESSAGES/libvirt.mo
share/locale/fa/LC_MESSAGES/libvirt.mo
share/locale/fi/LC_MESSAGES/libvirt.mo
share/locale/fil/LC_MESSAGES/libvirt.mo
share/locale/fr/LC_MESSAGES/libvirt.mo
share/locale/fur/LC_MESSAGES/libvirt.mo
share/locale/ga/LC_MESSAGES/libvirt.mo
share/locale/gl/LC_MESSAGES/libvirt.mo
share/locale/gu/LC_MESSAGES/libvirt.mo
share/locale/he/LC_MESSAGES/libvirt.mo
share/locale/hi/LC_MESSAGES/libvirt.mo
share/locale/hr/LC_MESSAGES/libvirt.mo
share/locale/hu/LC_MESSAGES/libvirt.mo
share/locale/ia/LC_MESSAGES/libvirt.mo
share/locale/id/LC_MESSAGES/libvirt.mo
share/locale/ilo/LC_MESSAGES/libvirt.mo
share/locale/is/LC_MESSAGES/libvirt.mo
share/locale/it/LC_MESSAGES/libvirt.mo
share/locale/ja/LC_MESSAGES/libvirt.mo
share/locale/ka/LC_MESSAGES/libvirt.mo
share/locale/kk/LC_MESSAGES/libvirt.mo
share/locale/km/LC_MESSAGES/libvirt.mo
share/locale/kn/LC_MESSAGES/libvirt.mo
share/locale/ko/LC_MESSAGES/libvirt.mo
share/locale/kw/LC_MESSAGES/libvirt.mo
share/locale/kw@kkcor/LC_MESSAGES/libvirt.mo
share/locale/kw@uccor/LC_MESSAGES/libvirt.mo
share/locale/kw_GB/LC_MESSAGES/libvirt.mo
share/locale/ky/LC_MESSAGES/libvirt.mo
share/locale/lt/LC_MESSAGES/libvirt.mo
share/locale/lv/LC_MESSAGES/libvirt.mo
share/locale/mai/LC_MESSAGES/libvirt.mo
share/locale/mk/LC_MESSAGES/libvirt.mo
share/locale/ml/LC_MESSAGES/libvirt.mo
share/locale/mn/LC_MESSAGES/libvirt.mo
share/locale/mr/LC_MESSAGES/libvirt.mo
share/locale/ms/LC_MESSAGES/libvirt.mo
share/locale/my/LC_MESSAGES/libvirt.mo
share/locale/nb/LC_MESSAGES/libvirt.mo
share/locale/nds/LC_MESSAGES/libvirt.mo
share/locale/ne/LC_MESSAGES/libvirt.mo
share/locale/nl/LC_MESSAGES/libvirt.mo
share/locale/nn/LC_MESSAGES/libvirt.mo
share/locale/nso/LC_MESSAGES/libvirt.mo
share/locale/or/LC_MESSAGES/libvirt.mo
share/locale/pa/LC_MESSAGES/libvirt.mo
share/locale/pl/LC_MESSAGES/libvirt.mo
share/locale/pt/LC_MESSAGES/libvirt.mo
share/locale/pt_BR/LC_MESSAGES/libvirt.mo
share/locale/ro/LC_MESSAGES/libvirt.mo
share/locale/ru/LC_MESSAGES/libvirt.mo
share/locale/si/LC_MESSAGES/libvirt.mo
share/locale/sk/LC_MESSAGES/libvirt.mo
share/locale/sl/LC_MESSAGES/libvirt.mo
share/locale/sq/LC_MESSAGES/libvirt.mo
share/locale/sr/LC_MESSAGES/libvirt.mo
share/locale/sr@latin/LC_MESSAGES/libvirt.mo
share/locale/sv/LC_MESSAGES/libvirt.mo
share/locale/ta/LC_MESSAGES/libvirt.mo
share/locale/te/LC_MESSAGES/libvirt.mo
share/locale/tg/LC_MESSAGES/libvirt.mo
share/locale/th/LC_MESSAGES/libvirt.mo
share/locale/tr/LC_MESSAGES/libvirt.mo
share/locale/tw/LC_MESSAGES/libvirt.mo
share/locale/uk/LC_MESSAGES/libvirt.mo
share/locale/ur/LC_MESSAGES/libvirt.mo
share/locale/vi/LC_MESSAGES/libvirt.mo
share/locale/wba/LC_MESSAGES/libvirt.mo
share/locale/yo/LC_MESSAGES/libvirt.mo
share/locale/zh_CN/LC_MESSAGES/libvirt.mo
share/locale/zh_HK/LC_MESSAGES/libvirt.mo
share/locale/zh_TW/LC_MESSAGES/libvirt.mo
share/locale/zu/LC_MESSAGES/libvirt.mo
@pkgdir share/gtk-doc/html/libvirt
@pkgdir share/doc/libvirt/examples/rename
@pkgdir share/doc/libvirt/examples/openauth
@pkgdir share/doc/libvirt/examples/object-events
@pkgdir share/doc/libvirt/examples/hellolibvirt
@pkgdir share/doc/libvirt/examples/domtop
@pkgdir share/doc/libvirt/examples/domsuspend
@pkgdir share/doc/libvirt/examples/dommigrate
@pkgdir share/doc/libvirt/examples/dominfo
@pkgdir share/doc/libvirt/examples/admin

2
libvirt/TODO Normal file
View File

@ -0,0 +1,2 @@
- Seems to be unable to communicate with libvirtd via socket.
(Maybe take a look at systemd scripts for comparison)

16
libvirt/buildlink3.mk Normal file
View File

@ -0,0 +1,16 @@
# $NetBSD$
BUILDLINK_TREE+= libvirt
.if !defined(LIBVIRT_BUILDLINK3_MK)
LIBVIRT_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.libvirt+= libvirt>=5.4.0
BUILDLINK_PKGSRCDIR.libvirt?= ../../wip/libvirt
.include "../../security/gnutls/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../devel/yajl/buildlink3.mk"
.endif # LIBVIRT_BUILDLINK3_MK
BUILDLINK_TREE+= -libvirt

10
libvirt/distinfo Normal file
View File

@ -0,0 +1,10 @@
$NetBSD: distinfo,v 1.8 2015/11/04 01:32:20 agc Exp $
SHA1 (libvirt-5.8.0.tar.xz) = e238bdbc68b4511ed972af26a8bd57dc12b02e40
RMD160 (libvirt-5.8.0.tar.xz) = 39bd8d5edf4a4c0cba11b80b5f384c05a8d1477a
SHA512 (libvirt-5.8.0.tar.xz) = 73d18fdf307b8029921a9f1a0c84ca31c50c662a3c0339e3850d6d2f31574168807a6f34943b286ed86a44031decbbc1339f27366da7269e29d38c7094503113
Size (libvirt-5.8.0.tar.xz) = 13129328 bytes
SHA1 (patch-configure) = 2bdc001882df499e4aadc0ddcb1bc0b4200eb2c8
SHA1 (patch-src_rpc_virnetmessage.c) = 989ddb4a75544e5a4c241d75e6fa01eadb6367f8
SHA1 (patch-src_util_virstring.c) = 2bffc4a5ff1d2fee0385a9c576e1d353d9b610dc
SHA1 (patch-src_vbox_vbox__XPCOMCGlue.c) = 8e201d5230437adc8aa40ac94c7429a55ab9c61c

22
libvirt/files/libvirtd.sh Executable file
View File

@ -0,0 +1,22 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: libvirtd.sh,v 1.2 2012/09/10 17:29:09 gls Exp $
#
# PROVIDE: libvirtd
# # REQUIRE: DAEMON network
# KEYWORD: shutdown
. /etc/rc.subr
name="libvirtd"
rcvar=$name
command="@PREFIX@/sbin/libvirtd"
command_args="-d"
if [ -f /etc/rc.subr ]; then
load_rc_config $name
run_rc_command "$1"
else
echo -n "${name}"
${command} ${command_args}
fi

View File

@ -0,0 +1,24 @@
$NetBSD$
Improve test portability to non-bash shells.
--- configure.orig 2019-06-03 14:10:18.291079910 +0000
+++ configure
@@ -63946,7 +63946,7 @@ _ACEOF
else
- if test "x$enable_nls" == "xcheck"
+ if test "x$enable_nls" = "xcheck"
then
enable_nls=no
else
@@ -63972,7 +63972,7 @@ _ACEOF
enable_nls=yes
else
- if test "x$enable_nls" == "xcheck"
+ if test "x$enable_nls" = "xcheck"
then
enable_nls=no
else

View File

@ -0,0 +1,30 @@
$NetBSD$
Handle netbsd's xdrproc_t only taking two arguments
--- src/rpc/virnetmessage.c.orig 2018-09-26 11:26:50.963410008 +0000
+++ src/rpc/virnetmessage.c
@@ -358,7 +358,11 @@ int virNetMessageEncodePayload(virNetMes
msg->bufferLength - msg->bufferOffset, XDR_ENCODE);
/* Try to encode the payload. If the buffer is too small increase it. */
+#ifdef __NetBSD__
+ while (!(*filter)(&xdr, data)) {
+#else
while (!(*filter)(&xdr, data, 0)) {
+#endif
unsigned int newlen = msg->bufferLength - VIR_NET_MESSAGE_LEN_MAX;
newlen *= 2;
@@ -416,7 +420,11 @@ int virNetMessageDecodePayload(virNetMes
xdrmem_create(&xdr, msg->buffer + msg->bufferOffset,
msg->bufferLength - msg->bufferOffset, XDR_DECODE);
+#ifdef __NetBSD__
+ if (!(*filter)(&xdr, data)) {
+#else
if (!(*filter)(&xdr, data, 0)) {
+#endif
virReportError(VIR_ERR_RPC, "%s", _("Unable to decode message payload"));
goto error;
}

View File

@ -0,0 +1,15 @@
$NetBSD$
We use "uselocale" too, so check for that in the macro as well.
--- src/util/virstring.c.orig 2019-03-26 13:50:10.521394891 +0000
+++ src/util/virstring.c
@@ -590,7 +590,7 @@ virStrToLong_ullp(char const *s, char **
}
/* In case thread-safe locales are available */
-#if HAVE_NEWLOCALE
+#if HAVE_NEWLOCALE && HAVE_USELOCALE
typedef locale_t virLocale;
static virLocale virLocaleRaw;

View File

@ -0,0 +1,15 @@
$NetBSD$
Have a case for netbsd.
--- src/vbox/vbox_XPCOMCGlue.c.orig 2018-09-26 11:26:50.994409695 +0000
+++ src/vbox/vbox_XPCOMCGlue.c
@@ -45,7 +45,7 @@
VIR_LOG_INIT("vbox.vbox_XPCOMCGlue");
#if defined(__linux__) || defined(__linux_gnu__) || defined(__sun__) || \
- defined(__FreeBSD__) || defined(__OpenBSD__) || \
+ defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__) || \
defined(__FreeBSD_kernel__)
# define DYNLIB_NAME "VBoxXPCOMC.so"
#elif defined(__APPLE__)