mozjs78: Fix build with newer macOS SDK

TODO: Fix dynamic library name
This commit is contained in:
Dan Cîrnaț 2020-11-08 22:36:17 +01:00
parent 9f6eadf629
commit b452fddbf8
2 changed files with 16 additions and 0 deletions

View File

@ -5,6 +5,7 @@ RMD160 (mozjs78_78.3.0.orig.tar.xz) = f2d9b5d71c9603ec3b2d80b4ef930c0f00948584
SHA512 (mozjs78_78.3.0.orig.tar.xz) = a28a582eae9d483ba7625236e2226392c9e26d5a10c4f34bee899ce27329dc0e9ba1dca96090597723a62d4f4a14f9dd339effae5db471a27eb32aa2ef2f0e8b
Size (mozjs78_78.3.0.orig.tar.xz) = 58324248 bytes
SHA1 (patch-.._.._build_moz.configure_rust.configure) = a40ef515b34781d703e9222e4c88746544556287
SHA1 (patch-.._.._build_moz.configure_toolchain.configure) = 055312319a6a4e2916263baf318585b943c1ca20
SHA1 (patch-configure.in) = e8dab4a549e5cdf2e97d65b258970f9f6cc9c72c
SHA1 (patch-jsfriendapi.h) = c6eea8b37d44a4b0f9ca0a325e482d01ef2c6e0f
SHA1 (patch-vm_ArrayBufferObject.cpp) = 931695e3e02ec1d6ed0f722be1059c48878cd117

View File

@ -0,0 +1,15 @@
$NetBSD$
Builds fine on MacOS with newer toolchain
--- ../../build/moz.configure/toolchain.configure.orig 2020-09-25 09:22:51.000000000 +0000
+++ ../../build/moz.configure/toolchain.configure
@@ -141,7 +141,7 @@ with only_when(host_is_osx | target_is_o
@imports(_from='biplist', _import='readPlist')
def macos_sdk(sdk, host):
sdk_min_version = Version('10.11')
- sdk_max_version = Version('10.15.4')
+ sdk_max_version = Version('10.15.6')
if sdk:
sdk = sdk[0]